Yet another one suggestion for player improvement

  • 2
  • Problem
  • Updated 2 years ago
  • Acknowledged
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Bug is closed.

This morning we received a call that some portion of the display was blank. Sure enough, most of the display was white with only one placeholder showing image slideshow. I did not investigate much, but it looks like the background and footer images failed to upload. I restarted the player and all came back on screen again. This is not typical issue.

- Windows 10 Intel Compute Stick
- Wired Ethernet connection
- All images in the Rise Storage
- Player set to reboot every night

Perhaps there was some rare Internet connection interruption at night, which resulted in portion of the screen left without content. Player was perfectly accessible remotely and seen by the RV system. I know there is 'watchdog' in place making sure that the player is running. In addition it could track if all the content was uploaded and force the 'refresh' if not (complicated solution). Or it simply could 'refresh' the player content every X amount of time (could be manually set and enabled/disabled in the display management App) similarly to what 'Publish' button does.

As it is now, the player would just stayed blank the entire day until the nightly reboot. And that is bad.

In addition, the player device needs forced reboot every X amount of time if it failed to access the Internet and connect to the system. As it is now, it would just stay in 'failed' mode indefinitely.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb

Posted 2 years ago

  • 2
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Darius,

If I understand you correctly, you effectively want a "restart Player if something did not load" feature built into the Player, or at least as an option that you can set. Do I have that right?

I know there are options that I believe you have used before where you can call the the restart script to kill and restart the Player. Would that be an idea for this machine?
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Robb, I would rather see optional 'refresh' (set in the display app: apps.risevision.com/displays) to resolve problems like that.

You are right, and after last nigh I started thinking about using a script to force refresh on our players. I though you might be interested too in making your app more reliable or at least giving an option for that.
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
Hi Darius, all of our Widgets have a built in refresh. As an example, if the Image Widget fails to load an image, say network was down, it will refresh in ~5 min. Assuming network is restored before that refresh occurs the Image Widget would then go get the image and show it on the Display.

Can you confirm what Widgets you are using where the related content is not showing? 
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Darius,

Thanks for that description! I logged a bug here that I think will solve this issue for you. 

Thanks!
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Robb, do not do it for me.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Darius,

I'm not doing it specifically for you, I logged it because it doesn't work as expected. You just helped us find it :)
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Darius,

I wanted to let you know that the issue I outlined above is set to be fixed and deployed around the second or third week of April. I'll be sure to let you know when it has been deployed!

Just as a reminder, a quick workaround would be to use the Image Widget as Alan suggested above, but that is just a workaround, once this is corrected, it will no longer be necessary.

Thanks!
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Robb, thank you guys for your work. 
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Darius,

We investigated this issue thoroughly, and it turned out to be more complex than we had originally thought, so we are going to continue investigating this instead of delivering a bandaid fix, as there are currently some workarounds for this issue.  The workarounds are you can force a refresh of the Presentation by making a change to the Presentation, restarting the display, or replacing the Presentation background with an Image Widget.

I hope that helps!
(Edited)
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Robb, I thought about some of them too. I am leaning toward 'refreshing' presentations every few hours oi so with JS. Easy thing to do. I want to stay away from using Widget for static background images for two reasons: eliminates clutter from the large number of widgets and background uploads faster.