X-Frame-Option denying Google Slides presentation from appearing

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

We've recently started to run into problems with Google Slides not appearing on our displays.

We have around 60 displays running on Chromebooks/Chromeboxes. Most are still running fine, but have a handful that over the past few days no longer show the slides.
.
Other page elements (logo, date/time) are unaffected. The Rise App itself appears to be loading in Kiosk mode with no issues.

When we view the preview in Chrome Browser (on a Windows PC), we're seeing a "Refused to display xxxxx in a frame because it is set to X-Frame-Options to deny".

No issues with our firewall - we've opened up everything to try and troubleshoot.

I've looked into that X-Frame-Options error, and based on the information out there, the slides shouldn't have worked at all.

I understand Chrome is no longer supported, but we tried on a Unbuntu installation and same issue.

I'm going to try to get this running on a Windows device to see if I can replicate the issue.

Anything I should be aware of?
Photo of Thomas Cash

Thomas Cash

  • 120 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Thomas, how exactly you run Google Slides in RV? I have no issues with slides in RV on Chromebox.
Photo of Thomas Cash

Thomas Cash

  • 120 Points 100 badge 2x thumb
Ok, solved it.

The sharing permissions were modified in Google Admin Console for the user that manages the signs across our organization. It was set to only allow content to be accessible by users in the domain.

Once we allowed sharing to all, we were able to restore the publishing settings.

It was challenging to figure out because this was only impacting about a dozen of our signs, even though they were all set up the same way with the same user (the only variable being a different Google slideshow).
Photo of DtheGreek

DtheGreek

  • 996 Points 500 badge 2x thumb
I'm Having the same issue but all my sharing settings look ok.  Any other possibilities?
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
DTheGreek,

Can you follow the steps listed in this forum post and let us know if your Google Slides show after following those steps?
Photo of DtheGreek

DtheGreek

  • 996 Points 500 badge 2x thumb
That did it.  Thanks Rob.