Windows 10 - RiseVision keeps setting Power Options - Power Saver

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Everytime RiseVision starts on our windows 10 machines it keeps setting the Power Options - power plan to Power Saver.  This is degrading performance of those machines in order to save energy, but is not necessary for our configuration.  Is there a parameter or way to prevent RiseVision from setting this?

Thank you!
Photo of Kyle Engibous

Kyle Engibous

  • 194 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Hi Kyle,

I just installed the latest version of the Win 10 32 Bit Installer, and my Display is still set to Balanced in the Power settings.

Just to be sure, I rebooted the box, let it come back up and start playing a Presentation, and it is still set to Balanced.

Can you confirm if you are on 64 or 32 bit Windows? Maybe there is something unique to that OS that is changing it over.

I look forward to hearing from you!
Photo of Kyle Engibous

Kyle Engibous

  • 194 Points 100 badge 2x thumb
Thanks Robb - I am using the Win 10 64bit Installer
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
My apologies Kyle,

I guess I didn't give it enough time to change over. I notice that after the Player starts up and starts running, the Power Saver setting is indeed enabled. I am going to follow up with our Development team and I will let you know if there is a way to stop it from changing this shortly.

Thanks!
Photo of Kyle Engibous

Kyle Engibous

  • 194 Points 100 badge 2x thumb
Thanks Robb! please keep me posted.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
I was reading before that Windows 10 sometimes does not register customer's power settings. The advice was to restore to the default settings and then apply yours again. I even had this kind of thing going on with one of our Intel Compute Sticks. I did just that and the problem went away. However, I am not 100% positive that it actually was the solution or there was something else going on. Also, I would check power settings in BIOS just to make sure there aren't any 'power saving' settings applied.
Photo of Kyle Engibous

Kyle Engibous

  • 194 Points 100 badge 2x thumb
I am running the same msi installer on each.  These devices are joined to our domain. Also looks like Robb was able to produce the issue.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Now I am concerned, how he was able to reproduce this? Why I do not get this... or maybe I did, but was not aware of that?

p.s. just out of curiosity I connected to my test Intel Compute Stick that has been running for weeks no problem with scheduled daily restart. In Windows 10 Interface it shows settings as NEVER go to sleep and turn off the screen, BUT when I select additional power settings it shows POWER SAVER selected. BUT like I said, it never goes to sleep or shuts down. Furthermore... I looked what are these 'power saver' settings, and it has both set to NEVER.  Perhaps you are still missing some settings?... can you confirm and under 'Power Saver' settings you have 'Turn off display' and 'Put computer to sleep' set to NEVER.
Photo of Kyle Engibous

Kyle Engibous

  • 194 Points 100 badge 2x thumb
My issue is not with things going to sleep.  Having power saver selected does things like caps CPU speed in order to save power.  I have observed some sluggish performance as result of being in power save mode.  For example just shutting down rise vision (crtl shift q) is very slow.  Turning off display or machine going to sleep is not the issue I am having.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Got it! Thanks for bringing this up, though. I had no clue )))
Photo of RPTDigital Signage

RPTDigital Signage

  • 2,284 Points 2k badge 2x thumb
Kyle:

I know I'm the guy always talking temperature, but especially on atom based processors and passively or minimally cooled players it's a more common problem than some people think when diagnosing sluggish response.

So, once you're sure any power save mode is disabled, if you get sluggish performance make sure your player isn't running hot and CPU throttling. When a player, especially Atom based, gets to max CPU temperature they do get very sluggish and keyboard response can get very slow, sometimes on a heat soak test we impatiently try 4-5 times to stop Rise before it actually reacts to the first stop,

Try downloading and running a free utility CoreTemp and make sure you've got thermal headroom. You can use Windows Task Manager as well, but when throttling TaskManager doesn't always reflect CPU load properly.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Kyle, Darius,

We are going to be correcting this behaviour with an updated release very shortly. Thank you for bringing this to our attention!

Photo of Kyle Engibous

Kyle Engibous

  • 194 Points 100 badge 2x thumb
Awesome thanks Robb!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Gentlemen,

Just wanted to let you know that this was deployed over the weekend, so if your Displays rebooted, they got this update. If they did not reboot, simply reboot them, and they should get this new version of the Player when they start up.

Thanks!
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Alright, I see it is working! Thank you guys.
Photo of RPTDigital Signage

RPTDigital Signage

  • 2,284 Points 2k badge 2x thumb
I confirm its fixed as well. Great response time