Why does the RSS widget parse HTML in the description tag but not the content tag?

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

This is the RSS widget loading an RSS feed that uses the <description> tag for the full contents of the article. Note that this styling is not done with the layout. It is the actual HTML contained within the RSS feed's <description> tag.



This is a screenshot of a feed that uses the <content> tag:


Note that in the second screenshot, the source code from the feed looks like this:

<content:encoded><![CDATA[<h3 class="text-align-center">This session was held on June 27, 2017</h3><hr /><p>JDSA Law is presenting a seminar on
The first sentence of that article should be in an <h3> tag and the rest should be in a <p>. All of the HTML tags are stripped out despite the fact that the <content> tag is technically the only tag in an RSS feed that should contain HTML.

Why is the <content> tag not rendering HTML properly?
Photo of Chris - Fantastitech

Posted 1 year ago

  • 1
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Hi there Chris,

Let me ask one of the members of our Dev team about this so I can get you an answer.

Thanks!
Photo of Stuart Lees

Stuart Lees, Employee

  • 586 Points 500 badge 2x thumb
Hi Chris,

Can you provide the two different RSS feed URLs so we can take a closer look? 

Thanks
"News" feed that has content in <description> tag: https://www.jdsalaw.com/news/?format=rss

"Seminars" feed that has content in <content encoded> tag: https://www.jdsalaw.com/seminars/?format=rss

Interestingly, the "seminars" feed also has a description tag that has a short preview but that's ignored in favor of the <content> tag. But when using the <content> tag for the feed content, the HTML is not parsed by the RSS widget causing issues with line breaks and other formatting issues. The HTML contents of the <content> tag should be parsed the same as the <descirption> tag is in the news feed.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Thanks for this information Chris! I have logged a bug for this that you can see here, and we are going to investigate this.

Thanks!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Chris,

Are you still seeing this issue? A member of our development team started looking at this yesterday and was not able to recreate it. Can you let me know if you are still seeing it, and if so, can you email support@risevision.com with a link to the Presentation you are having this issue with?

Thanks!