Website in webpage widget is cut off at the bottom with vertical scroll

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I'm having a problem with the vertical scroll on a webpage widget. I've put 293 pixels on the vertical scroll to cut off the banner at the top of the website, but it seems the bottom of the website is cut off too. I didn't have this problem before, so I'm surprised it's doing it now.

I have a demo of my presentation, where the problem is replicated under the "Directory" page: http://preview.risevision.com/?type=presentation&id=b454c4da-7138-44c2-8a1d-cca43b62d1b0

Is there a way to fix the webpage widget so that vertical scroll doesn't cut off the bottom of the webpage?

Thank you for your help!
Photo of Iris Kwok

Iris Kwok

  • 372 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Iris,

Can I ask the name of the Placeholder you have this webpage Widget in? I have your Presentation open, but I see there are a lot of content in there :)

Thanks!
Photo of Iris Kwok

Iris Kwok

  • 372 Points 250 badge 2x thumb
Ah, sorry! The placeholder is named 'Directory'.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Thanks Iris! I'll investigate this and get back to you as soon as I can.

Thanks!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Iris,

I think this is due to the size of your Placeholder. Notice this screenshot:


If I increase the size of the Placeholder, I can get all the images in there. If you want to get all the images in there, but leave the Placeholder size the same, one option you may want to try is zooming the webpage out, or in to fit the Placeholder's dimensions.

Thanks!
Photo of Iris Kwok

Iris Kwok

  • 372 Points 250 badge 2x thumb
I'm trying to fit the placeholder within the box I made in the template so unfortunately I can't change the size. Adjusting the zoom also did not show everything as I need to be able to scroll all the way to the footer.

It's just a little confusing since I was able to scroll to the footer before, and that was only around a month ago.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Iris,

If you need to scroll, can you check the box "Allow Interaction" and then select "Scrollbars Enabled"? Will that work for you?
Photo of Iris Kwok

Iris Kwok

  • 372 Points 250 badge 2x thumb
Scrollbars are enabled, it just doesn't scroll all the way down. Though it sort of looks like it technically scrolls to the end, but it's not visible within the placeholder?
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
That's what I am thinking. When you look at that page and scroll to the bottom, there is some text at the bottom, right? 
Photo of Iris Kwok

Iris Kwok

  • 372 Points 250 badge 2x thumb
Yes, the page has footer, it just doesn't show within the window.

I changed the "Appointments" placeholder to have the same website but no vertical scroll set to give a comparison.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Ah...THANK YOU! Now I see what you mean, I was going crazy there for a bit, confusing myself!

I will get this looked at by our Dev team asap.

Thanks!
Photo of Iris Kwok

Iris Kwok

  • 372 Points 250 badge 2x thumb
I probably should've done that from the beginning hahaha...

Thank you so much!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Iris,

We've released a fix that solves this issue, so if you can save your Presentation, you'll get the updated version of the Widget that solves this issue.

Let me know how you make out!
Photo of Iris Kwok

Iris Kwok

  • 372 Points 250 badge 2x thumb
They all work now!
Thank you so much!
(Edited)
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Fantastic!