Webpage widget creating millions of hits...

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
  • (Edited)
Hi community

I have problems with the web page widget
In my presentation, I have a widget showing a Web page containing a google calendar from a Joomla page. This setup works fine for about 10 days after which it is no longer possible to see the web page.

When I log in to my calendar page statistics I can see that has come almost 4 million hits on the last days of http://s3.amazonaws.com/Widget-Web-Page/web-page.html?up_scroll-horizontal=40&up_scroll-vertical...

I have set the page to refresh every 30 minutes in Rise Vision, but I experience that is almost 200 requests per second. So much that my web host blocks access to the site.

There are 5 displays, mainly Android mini-PC running My Rise Player.

Any ideas?

Best regards
Henrik Taaning
Photo of Henrik Taaning

Henrik Taaning

  • 80 Points 75 badge 2x thumb

Posted 4 years ago

  • 1
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
How long have you had these with that presentation up? Was this the first time this happened or has this occurred once before? How long do the devices run? What version of android you running? Also we have done some recent updates to the player so something could have happened when it got the update. Usually updates dont cause problems but i have seen some do weird things when they do get updated, so I'm not ruling that out. With android it could be anything especially 4.2.2 devices and it also could be something the webpage widget as well. Probably need to clear cache and monitor them and see if it occurs or starts to occur again. 
Photo of Henrik Taaning

Henrik Taaning

  • 80 Points 75 badge 2x thumb
The presentation has been up since may. The hit attack started on 3. july 2014 and contimued until 30. september where I moved the webpage to another host, to avoid the block.

After a few days the hit attack started again...

Players are running version 3.001 and 2.005. (For some reason some of them wont upgrade) It is RIKOMAGIC MK902 QUAD CORE MINI PC. 

I changed the weblink in the webpage gadget back to the original site today .

I am monitoring my webpage via Adwords, and at the moment I have no errors. But two of the displays are offline at the moment.. (The displays are more that 60 miles away, so I cannot just restart them...)

I am trying to get someone to reboot the two missing displays...
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
Usually with google updates you have to check mark update app automatically so thats probably why they haven't updated. 3.001 is the latest version and 2.005 is way behind. I would have them updated because that might be the issue because so much has been changed and i believe a memory leak was cleaned up as well. Also with 3.000 and above cache will be cleared at every schedule restart so that might be something to set up  on your display through the rise platform.