Web page widget not working properly when adding browser

  • 1
  • Question
  • Updated 2 years ago
  • Answered
If I want to load a browser and have it interactive which works when I configure it, it does not: 1. Show the URL bar, and 2. When they click the link after the search in the browser nothing happens. Any thoughts. Thanks.
Photo of Charles Craparotta

Charles Craparotta

  • 442 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Charles Craparotta

Charles Craparotta

  • 442 Points 250 badge 2x thumb
This is on a Pi-2 or 3.
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
It won't show the URL bar since the URL bar is part of the 'browser space' rather than what is available within the website, if that makes sense. Or, the URL bar is part of what you see on software like Internet Explorer, Chrome, etc but it's not part of the actual website so it won't be shown if you are embedding it.
If nothing is happen after an action is made (ie clicking a link) check that 'Allow Interaction' is enabled in the Web Page Widget and deselect 'Hide Mouse Pointer' in the Presentation Settings. You can also check to see if the issue happens on another website example. Otherwise it may be something specific to being on Pi 2/3. You can also cross post on the Raspberry Pi thread at https://community.risevision.com/rise...
Photo of Charles Craparotta

Charles Craparotta

  • 442 Points 250 badge 2x thumb
Yes, that makes sense. On the Allow interaction and mouse pointer, those are activated and still no response. I tried multiple sites. I believe it's a Pi issue. I posted and waiting to see if anyone else has the issue. Thank you.