Web Page Widget Not Displaying on Player

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
I have this link: http://iflyatl.com/security_wait_time.aspx posted in my presentation. It worked yesterday in both the preview and live player but today it's only showing in the preview. When I play the presentation, it shows a broken link. I tried changing the widget to a "content by URL" and both did not play in the live player.
Photo of Justin Idle

Justin Idle

  • 130 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Justin Idle

Justin Idle

  • 130 Points 100 badge 2x thumb
I just realized that the web widget shows up when I play the presentation on another display but my primary display is not showing the widget. I tried rebooting the player and the computer. No changes. It worked fine yesterday. 
Photo of Justin Idle

Justin Idle

  • 130 Points 100 badge 2x thumb
This is what I'm seeing (See bottom middle)
Photo of Justin Idle

Justin Idle

  • 130 Points 100 badge 2x thumb
Disregard. I realized it's not loading in the browser either. It's a problem on my end. Semi related though, how do I get interactive hyperlinks in the presentation to open up in a browser when I click on them? The links are clickable but they don't open any browsers. 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Justin,

They will not open up a browser, they will only open the page clicked in the current web page widget.
Photo of jeff

jeff

  • 4,150 Points 4k badge 2x thumb
I have an issue using the web widget that just started today (or maybe over the weekend.

I have been using the web widget to display a couple of web pages in a presentation for a number of weeks now.  No problems so far until this AM when the client send me a picture of the screen.  It was blank anywhere that web widget content was supposed to be showing.  Things look fine in preview mode. I restarted player, rebooted pc, all to no avail.

URLs display fine in browser.

I replaced web widget with content by URL and that works fine.  Downside is that I've lost the ability to refresh, which I need.

Hep me hep me!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
I'm not aware of any reason Win 7 Home would work differently myself. I haven;t done a lot of testing on Home, but I am sure there are some users out there with it on their own machines, such as yourself :)

When you run Display 2 with the same ID as Display 1, Display 1 will give a message that the Display ID is in use somewhere else. That won't go away until you turn off Display 2, and restart Display 1. I'm not sure why that didn't happen in this case. The first thing that comes to mind was something was being blocked on the network so the Player couldn't get out. That would be why you're seeing a load screen instead of the message, but that is just a guess.

The GitHub stuff is indeed there for you to take and do as you please, so if you find a programmer who could assist, i'd be very interested to see what you could build!
Photo of jeff

jeff

  • 4,150 Points 4k badge 2x thumb
I'm sorry I wasn't clear; the message screen was indeed what came up on the errant Win 7 machine.  It behaved as it should. It was intriguing that the machine started working correctly after one of these two events happened.

Thx for the GitHub intel; what is a link to give a road map of which folder/item to modify to change the interface that we log into and the subsequent screen for presentations, displays, etc.?
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Jeff,

I don't have a specific link to give a roadmap of what to modify, but your Developer should have all they need with the Github links listed at the bottom of the Create a Display page, which I have listed again here:

I hope that helps!
Photo of jeff

jeff

  • 4,150 Points 4k badge 2x thumb
Robb,

I am talking to a developer, and we were browsing about through some of the Rise-Vision folders on github. He thinks this will allow us to create a white-labeled player or viewer, but isn't sure if this will allow us to create a white-labeled application for a user to log into and edit their presentation.

Is the Rise-Vision platform in these open source folders, so that we can create a white-labeled interface for developing/previewing/publishing/etc. presentations?

Thanks, Jerff
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Jeff, the "core" itself, which is what drives the entire platform is private, however you can look at the core API here: https://github.com/Rise-Vision/core-api

Let me know if that answers your question.