Web Page Widget & Google Slide

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
I have this slide in the Web Page Widget, but the placeholder area is blank when I preview. I'm using the new editor, but it also doesn't work in the old editor. The placeholder is front with a z-order of 2.

Google Slide
https://docs.google.com/presentation/d/1WPz51n08UQFbyvq8_PXYj1z78xlX5f2uEplUHA8GekM/pub?start=true&a...

Rise Presentation Preview
http://preview.risevision.com/?type=presentation&id=be928e87-cd42-4d6a-80bc-1dd5a7765ac9&sho...
Photo of CedarNate

CedarNate

  • 434 Points 250 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Ashleigh

Ashleigh

  • 3,740 Points 3k badge 2x thumb
Hi there,

Is there a particular reason why you are using the Web Page widget for your slides?

Have a look at this article: https://community.risevision.com/rise_vision_inc/topics/how-to-set-up-google-slides-in-your-presenta...
You may have more success using our HTML widget to embed your slides.

Does this help?
Photo of CedarNate

CedarNate

  • 434 Points 250 badge 2x thumb
Yes. The auto refresh every 60 minutes setting. The widget is is working correctly on presentations that I've previously created.
(Edited)
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
CedarNate,
Just had a go at your presentation - see my version at http://preview.risevision.com/Viewer.html?type=presentation&id=2a0ae2bd-b723-4891-856d-8481bd2bb...

Modify the Google Docs link to the one below (I've changed pub to embed)

https://docs.google.com/presentation/d/1WPz51n08UQFbyvq8_PXYj1z78xlX5f2uEplUHA8GekM/embed?start=true...

In my version, I deleted the previous Web Page Widget placeholder and added another Web Page Widget placeholder but it should be fine if you replace use the link you were using to the other Google Docs link

Thanks
Hannah
Photo of CedarNate

CedarNate

  • 434 Points 250 badge 2x thumb
Thank you for your help. I can see your's just fine, and that's exactly what I'm trying to do. However, mine all show nothing. I made the adjustment from the "pub" to an "embed" but there's no change. Even removed the Widget and re-added it. No change.

http://preview.risevision.com/?type=presentation&id=be928e87-cd42-4d6a-80bc-1dd5a7765ac9&sho...
(Edited)
Photo of CedarNate

CedarNate

  • 434 Points 250 badge 2x thumb
I got it working by specifying the URL immediately when I added the Widget, instead of adding the Widget with empty values and then later modifying it.
(Edited)
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi,
I went into the presentation again, and copied the code and when I preview it from my own account I can confirm that I'm getting the blank screen as well.  I've set the data refresh interval from Do Not Refresh to 5 and still getting a blank screen.

I went back to the other two versions (ones based on the Preview links I posted earlier) and changed the data refresh interval from 5 to Do Not Refresh and I can still see the Google Doc.  

I think that there may be something affecting this widget in the original presentation's code.  Was it created entirely in the new Editor?  Or did you switch between the RVA and the new Editor at some point?  Also was this created recently (ie today)?

This is what I've done in RVA:
1. I went into your presentation 'NEW-WTS-Main'
2. Copied the HTML code
3. Created a new presentation 
4. Pasted the code
5. Deleted the Web Page widget and then added a new Web Page widget Placeholder
6. This is the result based on the actions above so it looks like it work: http://preview.risevision.com/Viewer.html?type=presentation&id=52397547-6620-432e-a201-7b86dd4f4...
(Edited)
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
CedarNate,
Thanks (sorry just saw the other reply above this one).
Photo of CedarNate

CedarNate

  • 434 Points 250 badge 2x thumb
Thank you for your help and quick responses.
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
(Edited)
Photo of Corey Koltz

Corey Koltz

  • 90 Points 75 badge 2x thumb
Thanks for this thread. I am using the new editor and I have verified this bug where you have to add it right away with a new placeholder or it doesn't display. I am copying settings from an original presentation which works fine and it wasn't displaying anything. Deleted the placeholder and created a new one, with the correct widget and settings and popped up. 
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Corey I had a look at the steps you mentioned and was not able to replicate.  Can you please let me know if the following were done so I can see if this is a bug that can be replicated and then sent to the team?

Steps I've done to reproduce:

1. In Editor add Placeholder 'Web Page Widget'

2. Add Web Page Widget in the Playlist

3. Press Apply (no changes).  Save and Publish.

5. Leave page, then go back Placeholder 'Web Page Widget'

6. The Playlist item still contains the widget

Photo of Corey Koltz

Corey Koltz

  • 90 Points 75 badge 2x thumb
They appear in the editor fine, it is when you are viewing the presentation that it wasn't appearing. As I stated in the post just below, it doesn't seem to be putting the type and timeDefined code in all of the time. I did this a couple times in recreating my presentation.
Photo of Corey Koltz

Corey Koltz

  • 90 Points 75 badge 2x thumb
Of note, I tried adding a calendar item and even when I did that, it didn't display properly. I looked at the HTML code and noticed this was missing underneath the id:

"type": "playlist", "timeDefined": false,

I added the code manually and it showed up fine. 
Photo of Brent Hillsman

Brent Hillsman

  • 112 Points 100 badge 2x thumb
I've tried this but not having any success.  My goal is to have a Google Slide show which students may update daily without having to restart the Rise players on the displays, so I want it to refresh every 5-10 minutes.  Slide show runs fine, just doesn't refresh.    
I used the old editor,  put in as HTML.

Here is the preview 

Here is the code I used in the HTML box.

<iframe src="https://docs.google.com/presentation/d/1Dqekqj-V10yt_vP-Bsx2pEvyKRPiVt_HNduXl5Nh128/embed?start=true...; frameborder="0" width="1566" height="909" allowfullscreen="true" mozallowfullscreen="true" webkitallowfullscreen="true"></iframe>
<script>
setInterval('reload()', 40000); 
function reload() {
    document.getElementById('iframeid').src += '';
reload();
}
</script>

Thanks for ideas to make this work.
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Brent

Please see https://community.risevision.com/rise_vision_inc/topics/how-to-set-up-google-slides-in-your-presenta...

The URL in the iframe src is not closed and there seems to be an extra " in it.  I am hoping that the comment that I wrote in the article (how to set up Google Slides in your presentation) is clearer.

Try below:
<iframe src="https://docs.google.com/presentation/d/1Dqekqj-V10yt_vP-Bsx2pEvyKRPiVt_HNduXl5Nh128/embed?start=true&loop=true&delayms=5000&slide=id.p"; frameborder="0" width="1566" height="909" allowfullscreen="true" mozallowfullscreen="true" webkitallowfullscreen="true"></iframe>
<script>
setInterval('reload()', 40000); 
function reload() {
    document.getElementById('iframeid').src += '';
reload();
}
</script>

Preview of your presentation using the HTML Widget (from Add > Content > HTML Widget) http://preview.risevision.com/Viewer.html?type=presentation&id=e524e741-fd0a-4fab-8cf0-563a90315...
Photo of Brent Hillsman

Brent Hillsman

  • 112 Points 100 badge 2x thumb
Slide show playing with both Corey and HSuarez suggestions.  Haven't verified refresh yet.  Thanks
Photo of Corey Koltz

Corey Koltz

  • 90 Points 75 badge 2x thumb
Don't use an HTML box, I use a Web Page, I then add the published to web page url with little modifications, 

https://docs.google.com/presentation/d/<YOURSLIDECODE>/embed?start=true&loop=true&dela...