Weather Gadget shows in preview but will not come up on display's

  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
We are about to deploy several RiseVision display's throughout our School District in Northern Michigan.  The only issue we have run into is getting the Weather Gadget to display.  It shows great on the preview but does not show up on any of our display's.  We are using the most current "amazon" Weather Gadget.  I have noticed that the first time it previews on a machine we've had to allow Google to accept location services. We currently have location services allowed for all sites and locked by the administrator but it still will not display.  I've also tried to open the RiseVision admin on the same machine running the presentation and previewed the same presentation that the machine was running and the preview showed the Gadget working but the actual presentation still would not display the Gadget.  Any Thoughts?   
Photo of Larry Burden

Larry Burden

  • 100 Points 100 badge 2x thumb
  • frustrated

Posted 4 years ago

  • 1
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Larry,

What media player and OS are you using?
Photo of Larry Burden

Larry Burden

  • 100 Points 100 badge 2x thumb
Windows 7, Chrome.  When you say media player are you referring to browser?  I didn't think the Weather Widget used a media player.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
I was asking about the hardware that is used to display the content, but it is not needed now.

It seems like something on either the media player or the network is blocking location services. Can you ensure this is not the case using the console and network tabs of googles developer tools? Simply open developer tools on the presentation and refresh, then see if you get any red error messages.
Photo of Larry Burden

Larry Burden

  • 100 Points 100 badge 2x thumb
Oddly, I attempted to drop a Accuweather html widget in and it does the same thing.  It's almost as though the RiseVision Player resets location services settings when it get's called up.  Curious.
Photo of Larry Burden

Larry Burden

  • 100 Points 100 badge 2x thumb
Gotcha, hardware is an HP 2102 laptop.  Very cool with the Developer Tools, didn't think of using it like that.  No luck though, several errors "Unsafe Javascript" errors with an iframed Google Presentation, but nothing with the Weather Gadget.  Scratch that, at the bottom there is the message Unknown RPC service: _noop_echo  Not sure if that has potential.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Larry,

Have you tried displaying using our chrome app player? I would be interested in knowing if you're experiencing the same phenomena.