Video Widget from Rise Vision

  • 1
  • Article
  • Updated 3 years ago
  • (Edited)
With the Rise Video widget you can easily show folders of videos from Rise Storage one after the other, or simply play a single video from any server. 

With Rise Storage folders managing what content shows where, is as simple as adding or deleting video files from a directory. Every time you upload a new file, or delete an old one, your displays are updated to show your latest video content. No need to find Presentations, select Placeholders and manually change Playlists. Managing video content is as simple as adding or removing video files from a folder. 

Don't have a Rise Storage account? Check out the free 30 day trial. Don't want to use Rise Storage? No problem! You can show single videos from a 3rd party server for absolutely free. 


Where do I host my videos? 
We recommend using Rise Storage, but you can host them from any 3rd party server that is publicly available. 

Do videos get cached locally? 
As long as you are using Rise Player, your videos will be cached regardless of where they are hosted. 

What video formats are supported?
We support WebM, and MP4 encoded as H.264.

Why do I see the message, "There was a problem playing that video. It could be that we don't support that format or it is not encoded correctly"
Make sure the format of your video is either WebM or MP4. 

An MP4 video must be encoded as H.264. You can encode your videos as H.264 using Handbrake which is free to use and compatible on Linux, Windows and MAC. 

If you are interested in converting your non supported file to WebM you can do so using Firefogg

Why do I see the message, “Please wait while your video is downloaded”
Your video must be downloaded before it can be shown. Download times will vary depending on network latency and the size of your video.
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Nathan Cummins

Nathan Cummins

  • 662 Points 500 badge 2x thumb
Hi Alan

I've not yet moved over to the Video Widget as the widget did not cache videos from anything other than Rise Storage, where I am using Amazon S3. A couple of my clients have very unstable internet connections, or their connections are extremely slow, so the Video Widget is effectively useless to me unless it caches from other sources. As I will be maintaining a couple of different companies, purchasing Rise Storage for each company is a little too expensive for my liking in order to maintain functionality that's already in place.

What is the status of this? Is there plans to allow caching from external sources, and will that be in place before the old gadgets are depreciated? I simply cannot move over to the Video Widget if the files are not cached.

Thanks for your help!
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
Understood Nathan. We are adding support for caching videos from non Rise Storage sources now. It will be ready soon. 
Photo of Nathan Cummins

Nathan Cummins

  • 662 Points 500 badge 2x thumb
Good to hear, Alan. Thanks for getting back to me!
Photo of AdGators AdGators

AdGators AdGators

  • 3,612 Points 3k badge 2x thumb
This is awesome news! Our advertisement displays have been subject to this issue for a long time. I'm happy to hear we'll have some caching for external sources. I will test as well.
Thank you Rise!
Photo of Thierry Masson

Thierry Masson, Champion

  • 2,356 Points 2k badge 2x thumb
Great. I'm going to test.
So as far as I understand, now, Video gadget uses cached where ever is the video saved; in Rise cloud storage or elsewhere.
Beautiful !
Photo of AdGators AdGators

AdGators AdGators

  • 3,612 Points 3k badge 2x thumb
To report: I am using 3rd party storage and when disconnecting my internet source from a presentation playing 5 .webM video's I lose the presentation 6-12 minutes after disconnection. I either get a frozen image of my video or a blank grey screen. I've tested both both the CAP and Latest Linux Build Players.

Linux Ubuntu 14.04
Rise Vision Chrome App Player & RVplayer-installer.sh Player
i3 Intel
4GB Ram 
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
AdGators, we have not yet shipped support for caching videos on 3rd party servers so what you describe makes sense. :) Hang in there, it will be ready soon and I'll post an announcement once it has shipped. 

Thanks!
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
I have tested Video Folder Widget yesterday. I am not sure if you know, but it has some bug in it that makes 1st video play 2 times in a row before moving to the next one.
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
Hi Darius, this is by design to reduce the time it takes for video to be showing in your Presentation. For example, say I have two videos in my Folder. Video A is 1mb and Video B is 30 mb. Once Video A is downloaded we'll play it while Video B is downloading. 

Once Video B has finished downloading, the Widget will finish playing Video A, then add Video B as the second video in a playlist. Then the playlist will be restarted from the beginning - Video A > Video B.

Hope that helps.

Thanks!
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
I see. This is actually smart. Thank you Alan.
Photo of ManifestoDigitale

ManifestoDigitale

  • 462 Points 250 badge 2x thumb
I'm using video widget. i converted video with handbrake to mp4 (it is a 20 seconds video and it is 3.1mb) when i load presentation it appears a black screen with a red write "downloading video. Checking video cache". Then this sentence disappears and black screen remains... It will show other image but everytime it has to show the video a black screen appears instead.

Why?
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
MontiDanuni.com,

Looking at your Displays, I see that most are on older versions of both Player and browser.

Can you go to https://help.risevision.com/user/create-a-display and install the newest version of the Linux Player on the machines that are having issues to see if this corrects the 4/5 second wait time?

There is a newer version of the Rise Cache in this version which I am hoping shortens that blank time considerably.

Thanks!
(Edited)
Photo of ManifestoDigitale

ManifestoDigitale

  • 462 Points 250 badge 2x thumb
I'm testing it on Totem 2 and "Totem Test". both of them have last version (22 april). Totem 2 has the newest 64bit, totem test has the older 32bit version. Is there still a newest version? Now i try to delete cache and retry

EDIT: Still the same problem. (tested on 64bit version deleting home/rvplayer/risecache folder.
(Edited)
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
MontiDauni.com,

Sorry for the late response, I've been running the Presentation called "Test" for the last couple of hours. I wanted to give it some time to run, and from what I have seen running for the last few hours, I haven't seen any black screens in this Presentation called "Test".

I don't really see any videos though, have they all been removed?
Photo of ManifestoDigitale

ManifestoDigitale

  • 462 Points 250 badge 2x thumb
Yes, now i deleted it and i replaced it with images.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
OK, thanks for that clarification. Be sure to let me know if you see this issue again when you add videos to the Presentation.

Thanks!