video placeholder hangs on embedded presentation

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
Hello,
I'm using a presentation with a  embedded presentation with a video placeholder, the video sometime is being updated on the server, so it change size but the name remain the same. RiseCache update correctly and download the video again, I can see it from the RiseCache log, the new video plays correctly for some minutes but after a while it stop and the placeholder became grey with the loading circle.  If the video is not updated everything works fine. 
I'm using Ubuntu 14.04.

Can you help me?
Photo of Enp

Enp

  • 584 Points 500 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Enp,

Are there any errors in the chrome developer console?
Photo of Enp

Enp

  • 584 Points 500 badge 2x thumb
Hi Blake,
there'are no errors in the chrome developer console. looking the risecache log the updated video is downloaded correctly and it's also showed. so it hangs after show it.

this is risecache log (I've changed the URL with video n) as you can see video 1 is showed after donwload:

Jan 16 03:52:10.224 INFO: Download complete. Length=38357153. URL=video 1
16 03:52:10.230 INFO: File AB30B270.00000000.dat is deleted.
Jan 16 03:52:10.231 INFO: File AB30B270.00000000.txt is deleted.
Jan 16 03:53:48.234 INFO: Download cancelled. Response code 304 received for URL video 2
Jan 16 03:55:25.358 INFO: Download cancelled. Response code 304 received for URL video 0
Jan 16 03:58:07.329 INFO: Download cancelled. Response code 304 received for URL video 1
Jan 16 04:00:03.624 INFO: Download cancelled. Response code 304 received for URL video 2
Jan 16 04:01:40.617 INFO: Download cancelled. Response code 304 received for URL video 0

at this point the loading circe is showed and I've to restart presentation.

another thing I've noticed is that this usually happens when the changed video is much bigger/longer.

thanks,

Enp
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Enp,

I understand. This could be due to the way the player is caching the video. Since you're changing the file that it is requesting, you may need a player restart or system reboot in order to clear the cache.
Photo of Enp

Enp

  • 584 Points 500 badge 2x thumb
Yes, with a player restart it works fine. But this means to restart player every time the video change. As I told you this issue happen only when the video is embedded probably due to the fact that the duration in master presentation is not updated and play until done fail. This explain also why this issue happen only when updated video is longer. Is it possible to change player behavior to manage this situation?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Enp,

Would adding videos to your presentation individually and scheduling them to play be a better option than replacing the video in storage each time you want it to change? 
Photo of Enp

Enp

  • 584 Points 500 badge 2x thumb
Hi Blake,
the video are updated with  a batch job on the server, so I can't have control on it.

Thanks
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Enp,

It looks like this is an issue due to caching. You may be better off using our vimeo gadget to display this kind of content.