Using Frameworks for layout?

  • 1
  • Question
  • Updated 3 years ago
Are we not able to use a framework for layout within a presentation (Not a widget layout)? 

I've added hosted JS and CSS libraries required for the Framework in the <head> but they are not showing in the preview (Using Chrome Dev tools to view code) and the layout is not correct (Per how it should look with the framework).

Am I missing something here?
Photo of Eric S.

Eric S.

  • 7,412 Points 5k badge 2x thumb
  • confused

Posted 3 years ago

  • 1
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Glen,

I'm going to alert our Content team to this question. Someone from that team should have an answer for you!
Photo of Donna Peplinskie

Donna Peplinskie

  • 7,142 Points 5k badge 2x thumb
Glen,

I just tried loading the necessary Bootstrap files in the head of the Presentation HTML. I can see both bootstrap.min.css and bootstrap.min.js being loaded in the Network tab, and my layout is displaying as expected.

Which framework are you using?
Photo of Eric S.

Eric S.

  • 7,412 Points 5k badge 2x thumb
I am using UIkit using the jsdelivr CDN...

Here's my head (I just moved them to the top for testing since they didn't work elsewhere

<head>
<script src="https://cdn.jsdelivr.net/uikit/2.22.0/js/uikit.min.js"></script>
<link rel="stylesheet" href="https://cdn.jsdelivr.net/uikit/2.22.0/css/components/accordion.almost-flat.min.css">
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
<title></title>
</head>
Photo of Donna Peplinskie

Donna Peplinskie

  • 7,142 Points 5k badge 2x thumb
OK, I can confirm that both files loaded for me in preview.

If you leave the Network tab open and refresh, then filter the results by uikit, do you see those files? The Network tab needs to be open at the time of refresh in order to see the activity.

I'm not familiar with this framework though so not sure how to adjust the layout.
Photo of Eric S.

Eric S.

  • 7,412 Points 5k badge 2x thumb
After seeing the JS under Network tab but not the CSS I went and looked again.

Egg on my face! I had the wrong CSS file linked. All showing up now. 

It's one of THOSE days...
Photo of Donna Peplinskie

Donna Peplinskie

  • 7,142 Points 5k badge 2x thumb
It happens to the best of us. Cheers to figuring it out.