Ubuntu portrait mode problem

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
Hi,

i installed ubuntu, google chrome and risevision player. Then i set ubuntu to counterwise mode and risevision to autostart but i have a problem. When i start my pc it will first go for a second in landscape mode (and opens Risevision player) then it switchs to portrait but rv player already set itself to landscape (1920x1080) and so it won't update to 1080x1920 when it switch to portrait mode.

How can i solve it?

I tought to delay risevision player opening or to give priority to portrait service... but how can i do?

And, second, how can i hide mouse pointer?

Thanks a lot
Photo of Benito91

Benito91

  • 182 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Matthew Fisher

Matthew Fisher

  • 1,420 Points 1k badge 2x thumb
Benito91,

I'll answer the easier question first:  hiding the mouse pointer should just be a matter of changing the presentation settings (accessed by clicking on the cog wheel in the top right corner)--there is an option called "Hide Mouse Pointer" that can be checked/unchecked.  Also, while it shouldn't be necessary, you can install unclutter from the package repo with the command:  "apt-get install unclutter"

The introducing a delay to the player's startup is going to require a little command line work, so open up a terminal (and filenames can vary so there will be some additional steps that you'll have to fill in with your unique parameters)...
1) type "ls -l ~/.config/autostart"   (without the quotes)
2) among the files listed you should see something like "chrome-laksdjflksjadlkfjsdf.desktop"
    type "cat ./config/autostart/<your particular filename>"   (without the quotes and <>)
3) with the mouse, highlight everything after the "Exec=", right click and select copy.
4) type "gedit ~/cap-delayed-start.sh"   (without the quotes)
5) in the newly created file, type the following lines (excluding anything parenthetical comments):
    #!/bin/sh
    sleep 30        (you can change this to however many seconds you want the delay to be)
                         (paste the line you copied from step 3)
6) save and exit
7) type "chmod +x ~/cap-delayed-start.sh"
8) type "gedit ~/.config/autostart/cap-delayed-start.desktop"  (without the quotes)
9) in the newly created file, type the following lines (excluding anything parenthetical comments):
    [Desktop Entry]
    Type=Application
    Exec=/home/rise/cap-delayed-start.sh     (replace "rise" with whatever the correct username is)
    Name=Rise Vision Chrome App Player (delayed start)
10) save and exit
11) finally, open the Ubuntu dash (top left corner); search for and open Startup Applications
12) uncheck "Rise Vision Chrome App Player" and check "Rise Vision Chrome App Player (delayed start)"
13) reboot to verify


Have a good day,

Matthew
Photo of Benito91

Benito91

  • 182 Points 100 badge 2x thumb
i'm trying your procedure but i have some problem:

at point 2) i see my file but when i type "cat ./config/autostart/<your particular filename>" it says "no such file or directory"... i already tried "cat /.config/autostart/<your particular filename>"

The only thing that i noticed is that my file has a default before .desktop extension... and my startup risevision remind to desktop rv player icon...

I tried to go in startup application and set "sleep 30;" in command but this will get computer stuck at reboot.

Sorry for my english but i'm italian.
Photo of Matthew Fisher

Matthew Fisher

  • 1,420 Points 1k badge 2x thumb
Benito91,

I apologize for my lack of clarity.  In step 2, the filename can vary from machine to machine so there is no way I can specify a complete path that will work in all environments.

In my particular case, the path/filename is:
./config/autostart/chrome-mfpgpdablffhbfofnhlpgmokokbahooi-Profile_1.desktop
but that is probably not correct for anyone else.

The reason for step 1 is to get the file names in that directory so you can replace
<your particular filename> with the correct one for your system.

When you are able to successfully perform step 2, you will see several lines of text.  One of the lines begins with "Exec=".   You need to highlight and copy everything in that line, that comes after Exec= because it is used in step 5.
This is also unique to your system, so I can't provide a working example.

When creating the .desktop file in step 5, do not put any of the comments in parenthesis.
Your file should look like this (where xxxxxxxxx is pasted from step 3):

#!/bin/sh
sleep 30
xxxxxxxxxxxxxxx

I do realize that these steps can be complex and long, if the person isn't particularly comfortable with the command line, but there's not a very good way to make it more streamlined since there are so many variables.

I hope this helps and answers your questions,

Matthew
Photo of Benito91

Benito91

  • 182 Points 100 badge 2x thumb
Yes, i understood but when i copy and paste my file name it says "no such file or directory". Tomorrow il will post a screenshot to let you see
Photo of Benito91

Benito91

  • 182 Points 100 badge 2x thumb
ok, i achieved to follow your procedure (point 2 was wrong the correct string is: ~/.config/autostart/<your file name>


Anyways i still have the same problem. If i delay the player i will have graphic problem (as you can see from photo).

I'm using ubuntu 14.10 64bit if it needs... do you have any ideas?

Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
This looks like an Operating System issue, not related to Rise Vision player. Please consult Ubuntu's support department for this.
Photo of Benito91

Benito91

  • 182 Points 100 badge 2x thumb
ok thanks, so wich ubuntu version do you suggest to install to use with rv player?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
We test on Ubuntu 14.04 32bit.