UBUNTU installation problem - cannot execute binary file

  • 1
  • Problem
  • Updated 1 year ago
  • Not a Problem
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Hi,

trying to install on Ubuntu 14.04 after could not find the RV Chrome Extention for some reason. 



last lines of the installation:

Disabling Screensaver
Disabling inactive timeout
./"date+time"/initial-run.sh: line 39: /home/xxxxxxx/rvplayer/"date+time"/installer/installer: cannot execute binary file: Exec format error
"back to"    :~/Downloads$


Assistance will be much appreciated.

Thanks 

Eyal
Photo of Eyal Radomsky

Eyal Radomsky

  • 1,306 Points 1k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Ahmed Al-Sudani

Ahmed Al-Sudani

  • 142 Points 100 badge 2x thumb
Hi Eyal,

That error is likely caused by an architecture mismatch. The Ubuntu version listed on our website is for 64-bit machines. 

You can download the 32-bit version at http://install-versions.risevision.com/installer-lnx-32.sh.

However, please note that Ubuntu 32-bit installations are not officially supported. We recommend switching to Ubuntu 64-bit if you face any other issues.

Let us know if the problem persists.
Photo of Eyal Radomsky

Eyal Radomsky

  • 1,306 Points 1k badge 2x thumb
Hi Ahmed,

32 bit was indeed the issue.
Problem solved.
Thank you very much.

I do have a small issue though which I hope that you can assist me with although there is no official support for the Ubuntu 32 bit.


In one of the pages I have Web Page Widget.
This Web Page Widget does not show the URL/Web Page only in the Ubuntu 32bit.
It is OK on Windows Player 64, and Chrome Extensions running on Windows and Mac.

The same URL does also display properly if it is not in the Web Page Widget but in a regular URL page in the Schedule.

Thanks a lot,


Eyal 





 
(Edited)
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Eyal,

is it possible that it is running Flash and is missing the plugin? You can find more info on that here.

Thanks!
Photo of Eyal Radomsky

Eyal Radomsky

  • 1,306 Points 1k badge 2x thumb
Hi Robb,

I did as you have advised; did not work.


I changed the URL to various "regular" web sites (cnn for example), and at least one that I know has no Flash; there is still no content in the Web Widget - This is only in the Ubuntu.
Tried it on another Ubuntu 14.04 now.... same issue.

Same URLs are OK in Browsers and more importantly when displayed in the same Schedule as a regular URL page; but not in the Web Widget.


Thanks

Eyal 
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Eyal,

Can you share a link to your Presentation? I'd like to take a look for myself.

Thanks!
Photo of Eyal Radomsky

Eyal Radomsky

  • 1,306 Points 1k badge 2x thumb
Hi Robb,

Kindly provide your direct mail as this project is under NDA at the moment.

Thanks

Eyal
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
No problem Eyal, can you shoot it over to support@risevision.com?

Thanks!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Eyal,

I got your email, I will let you know what I can determine.

Thanks!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Eyal,

Please see my in app message to you. I was not able to recreate this issue on Ubuntu 32. Hopefully my recommendations in that message fix the issue.

Thanks!
Photo of Eyal Radomsky

Eyal Radomsky

  • 1,306 Points 1k badge 2x thumb
Robb,

Problem solved.

Indeed it was the matter of display on "Select Displays".

I Will definitely pay more attention to this setting next time.

Thanks a lot for your great assistance.

Eyal 
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Glad to hear it Eyal!
Photo of fix86

fix86

  • 120 Points 100 badge 2x thumb
Hi Robb,
I have Ubuntu 14.04 32 bit desktop version and I am trying to install the rise player. I download the 32 bit installer from Rise vision website. However, It throws me an error saying 'execute binary file: Exec format error'

I am not using a wrong architecture installer but still facing an issue. Kindly advise.