Ubuntu-based player, one monitor shuts off after a long time, other one doesn't.

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
I have a puzzling problem where two identical players behave differently. I have a pair of Acer N2620G machines, identical hardware and software, running two different shows in our lobby.

Over night, the screen on one powers off, while the other one stays on. The players themselves are up and running, only the monitor goes off.

The monitors are different brands, so my first thought was it was a difference in the display hardware, but I tried swapping the players and monitors, and the problem followed the player.

Since the hardware's identical and software was installed from a common image, the only possibilities I have left are some sort of difference in the OS or player configuration or settings.
Photo of Host Master

Host Master

  • 226 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of XMedia Dubai

XMedia Dubai

  • 2,786 Points 2k badge 2x thumb
just check the monitor setting options and the power options in ubuntu player
(Edited)
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
There's a section in the Linux Player Optimization guide that discusses the screen going dark.  You can read about it here about how to correct it.

Thanks.
Photo of Host Master

Host Master

  • 226 Points 100 badge 2x thumb
I've already checked the obvious settings, and I don't see anything that would account for the different behavior between the two players. Both are set to never suspend, both have the exact same xset values. Is there something else I should be looking at?
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Just for clarification, on the screen that goes blank, does it recover on its own, or do you need to move the mouse (or equivalent) to bring it back up? Also, do you know if the screen is going off at the same time every night, or does it happen after X hours?

If it happens at the same time every night and recovers on its own, can you check that the content in the Presentation is set to play always, and also check the Schedule to ensure that the Presentation within it is set to Always?
Photo of Jason Maggard

Jason Maggard

  • 2,620 Points 2k badge 2x thumb
Add this to your /etc/X11/xorg.conf 

Section "Monitor" 
Option "DPMS" 
EndSection 

Section "ServerLayout" 
Option "BlankTime" "0" 
Option "StandbyTime" "0" 
Option "SuspendTime" "0" 
Option "OffTime" "0" 
EndSection 

Also, you can add the following to your autostart.sh:

xset -dpms &
xset s off &

xset s noblank &
(Edited)