Two Google Spreadsheet Widgets on one display won't display properly on Raspberry Pi

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
I have Raspberry Pi's running RisePlayer. For any other widgets things display just fine. However I'm attempting to use the Google Spreadsheet widget. I have two instances where it pulls from two different spreadsheets. First I tried having a presentation display information from one spreadsheet in a placeholder. No problem. But if I add a second presentation with the same set up pulling from a different spreadsheet the placeholder appears empty. All I see is the background. I've tried having two presentations play in a schedule but the second presentation gives the problems. I've tried adding two widgets into one placeholder switching back and forth but the second always gives the problem. I've tried setting up a player on a different platform (Mac) and it plays no problem. If I change the order the widgets display or the scheduled presentation play it's always the second widget that won't display.

I cannot figure out why this is displaying the way it is. Any insight would be appreciated.

Hopefully this makes sense.
Photo of Trevor Laboucane

Trevor Laboucane

  • 82 Points 75 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 1
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Trevor,

We don't have a Mac Player, so I assume you were using the Chrome App Player on that device, is that correct?

Any chance you can try this on a Windows or Linux Display using our Player that you can download from https://help.risevision.com/user/create-a-display and let us know how you make out?
Photo of Trevor Laboucane

Trevor Laboucane

  • 82 Points 75 badge 2x thumb
Correct. I'm using the Chrome Player on the Mac. I have also set up a Windows machine to test on and the two spreadsheet widgets play just fine back to back. So that narrows in down to the Raspberry Pi. The Chrom player on Chromium doesn't play two spreadsheets back to back without turning the second one transparent.

Very strange behaviour. As I said. Other schedules seem to play fine.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Thanks for that confirmation Trevor!

To ensure this gets full attention, can I suggest asking your question in the official Riseberry thread, to see if other users using the same hardware have any suggestions?

Thanks!