Text displaying on top of text - jumbled presentation

  • 1
  • Question
  • Updated 1 year ago
Our college just started using RiseVision for the digital touch screens in two buildings. I built a few presentations and added them to the schedule. They looked great in preview, but on the screens, it was a jumbled mess, with text from one slide displaying on top of another, simultaneously. Troubleshooting I then tried:
  • making sure the duration on each presentation was 10 seconds
  • setting a play until done element on each slide. I tried this multiple ways: selecting the main text as the play until done element, which didn't work; selecting the main image as the play until done element, but that didn't work either; selecting the logo at the bottom of each presentation. So none of that worked.
  • removing all of the presentations except for one, and then creating placeholders within the slides, making sure each had a time limit of 10 seconds
  • taking the screens offline then back on again
The one slide that displayed correctly every time was the one with an image only, no text.

I have searched the community and beyond and can't find another mention of this, so I'm wondering if this problem is unique to us. Any help is appreciated!
Photo of UK College of Education

Posted 1 year ago

  • 1
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Honestly, I think problem is in how you set different elements in your presentations. basically you are doing something wrong. For example, PUD setting does not even work with text or image. This setting was introduced for videos. I've seen many users getting in trouble with PUD before.Also, it is pretty much impossible to tell what is wrong without looking at your presentations.

Just curious, you mentioned those were touchscreens. Are you actually utilizing this functionality with your presentations? If so, how? I wonder if that might have something to do with that hot mess you are getting.