Storage suscription

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
Hi,

While attempting to suscribe to the Storage, I encountered an error in the cart. My cart had a single item "12-month subscription" and the information at the top looked correct in the BillTo and ShipTo sections, but the bottom indicated a "No user" error. I tried several times but never was able to complete the order. The only button available was the "Continue Shopping" button.
Photo of Marc Lapierre

Marc Lapierre

  • 100 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Marc,

Can you please email support@risevision.com with your problem? Someone will get back to you right away.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Marc,

Can you try refreshing the pageto see if that solves the issue? Typically we've seen this issue when the window has been open long enough for the authentication to expire, requiring you to refresh the cart to authenticate again.

Please let us know if that solves the issue.

Thanks!
Photo of Marc Lapierre

Marc Lapierre

  • 100 Points 100 badge 2x thumb
Thanks guys. I tried this morning from a different computer and it worked. One comment though ... it'd be great to see some form of message indicating the transaction is secured when entering your credit card number. I saw the 'Powered by Stripe' label at the bottom but since there was no sign of HTTPS anywhere, I was a bit nervous of entering my CC number. Otherwise, the transaction seems to have gone through. Maybe a PayPal option (or similar) would also be a good alternate method of payment ...