Spreadsheet Gadget Not Displaying

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Come in this morning and our two menu boards are displaying no content.

Rebooted both machines (ASUS VivoMini with Windows 7) and republished presentation a couple times and no content is showing.

Content is also not displaying in the preview!!

This is kind of urgent to get fixed, especially since they approved $5k worth of hardware to do additional boards and they are going to pull that funding if these won't stay running properly!
Photo of Eric S.

Eric S.

  • 7,412 Points 5k badge 2x thumb
  • very upset again

Posted 3 years ago

  • 1
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Glen, 

If the spreadsheet data is also not showing in Preview, have you already checked the spreadsheet itself to make sure nothing has changed?  I assume you are using the Google Spreadsheet widget, not the gadget?

Can you please send the Preview link?
Photo of Eric S.

Eric S.

  • 7,412 Points 5k badge 2x thumb
Alex,
Nothing has changed in the spreadsheet other than content. I'm the only one with access and I've been gone since last week.

It is still using the SpreadSheet Gadget as we've had no time to do any changes with a massive system overhaul for the past 4 mo. I just started rebuilding these last week before I left.

Here is the link: http://preview.risevision.com/Viewer.html?type=presentation&id=f35682d3-4cf1-4581-9cd8-5f24661f1...
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Glen,

Thanks for the link.

It looks like the custom layout being used in that gadget is being automatically throttled for an extremely high download count.  It is being downloaded between 40 and 50 times per hour from 5 different IP addresses.  Can you look into what might be causing the high number of downloads and try to resolve that issue?  Currently the download threshold is 35 times per hour and numbers over that will cause the file to be throttled.

You can tell that the file is being throttled if you log into Rise Storage and take a look at the file - you will see a big red exclamation mark beside it.

If you switch to the default layout it may resolve the issue temporarily, although of course it may not format the content correctly.
Photo of Eric S.

Eric S.

  • 7,412 Points 5k badge 2x thumb
Uhhh, shouldn't you be able to me why it's being downloaded so often? It's your platform!

There are literally two devices ONLY running this presentation. I don't know how you are possibly seeing 5 IPs as you should only be able to see our external IP (Of which we have 2). What IP's are you seeing?

Nothing has changed on these devices in the past 6mo other than switching out Pi hardware for Windows hardware. Outside that, nothing but the content changes. Why would the system be continually downloading stuff it doesn't need to? It's not like I can go in and say 'download more often' or anything. 

We have an incredibly fast and reliable network (Outside of third parties digging up ISP cables a month ago) that powers our entire system across two clubs in two physically separate locations, if there was a network issue, we would know about it as our main system wouldn't be functioning. 

Changing the layout will certainly break it and make it just as unusable as it is now.
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Glen, since you said that those IP addresses don't belong to you, I dug a little deeper.  It must be that somebody has the presentation open in Preview where no caching takes place, so i can't tell what the true IP address is.  It turns out those IP addresses are from Google Cloud.  Is it possible to close all tabs that may have this presentation open, both in Editor and Preview?  After doing that let me know and I will check in a little while to see if the file throttling clears up.
Photo of Eric S.

Eric S.

  • 7,412 Points 5k badge 2x thumb
There was only a single tab I had open viewing that presentation. Currently none. I'm the only one with access to the Presentations and previews, so no idea where the other ones would be coming from...
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Thanks Glen.  How long ago did you close the tab?  
Photo of Eric S.

Eric S.

  • 7,412 Points 5k badge 2x thumb
I would say at least 20mins ago. Previous to that, my machine has been shut down since last week when I left on Vacation.
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Okay, it looks like that file is no longer being throttled.  Unfortunately at this point I can't tell what may have happened prior to today before you reported it.

FYI since you have multiple gadget instances, and Preview does not take into account the scheduling you had set up, it was downloading that layout file for each gadget instance when you previewed it.