Screens don't connect

  • 1
  • Question
  • Updated 3 years ago
  • Answered

We have 15 display 3 are not currently in use and two will not connect.

I have a known working config ( on of the other displays that are on ) this is copied to my new display, I then change the IP / Host name / DNS. To check I contact the Pi they have Vino installed, connection to the pi via VNC works OK, so I know its on the network, Then on the RV site I add a display and get an ID - KHDKJGYP9SV8. Then in the /home/pi/rvplayer/RiseDisplayNetwork.ini I change the display ID to the new ID leaving the claim ID as is, there are two URL's in this file

viewerurl=http://rvashow.appspot.com/Viewer.html
coreurl=https://rvaserver2.appspot.com

save and exit

then in the rise vision player script I check that the display ID is correct

But it will not connect

I have done this method on the other displays and they have worked, is there any other setting I need to check

Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb

Posted 3 years ago

  • 1
Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb

update, So the Pi's will not connect, so I changed the IP to DHCP and put the pi on a DSL l line, and it connects

then changed the IP to static on our LAN rebooted and now it connects ( what's all that about :)

Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
TV Screens,

So it sounds like this is corrected by changing the IP to static, do I have that right?

Regarding Pi Players, you'll find a wealth of success in this post
Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb

Ah well it seems to have failed again, So I have used my working clone and changed the IP's and ID etc etc

but it fails to connect, What should I be opening up on the firewall, I have a list as long as your arm at present for the pi's to work, but its strange that loads work but some will not connect, but if I put it on the ADSL it works  but struggles via our lan

Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb
I think the pi is not hitting the risevison servers, but its very strange that some do and some don't
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Hi there,

The Create a Display page shows all the appropriate info for your firewall: https://help.risevision.com/user/create-a-display

I hope that helps!