RPI2 and RPI3 Window IOT

  • 3
  • Question
  • Updated 3 years ago
  • Doesn't Need an Answer
  • (Edited)
I have decided today to realease an early beta to my Windows IOT app. What i mean by early is that we still have a ways to go with the app but its good enough to let people use and play. 

What we have so far.
The app will ask for display id and Timezone. Id is easy and the Timezone is there to set the clock correctly on the device on bootup.

Image widget will cache Rise Storage files from both single image and folder. 

Restart and reboot works. Reboot will just reboot. Restart will delete cache and reboot.

Hitting escape or f1 when the presentation is on will get you back to the menu if you want to change display ids during testing. 

What we are working on or looking at. 
A better menu with more options. We made it simple for now so we could work on getting the presentation to show.

Hdmi-CEC controls or rs232. HDMI-CEC is our main choice but if it doesnt work or we have issues getting it to work we will use rs232. 

Testing: Microsoft has change alot of things so nothing is garantee to work for long periods of time. With each update they make, the more changes we might have to make. For now everything should work but wanted point this out incase it does happen.

App updates. As of now microsoft doesnt give a good way to update the app. Once they do, we will get that running as well. 

Images
There are two sets of images that can be used. I prefer everyone to use the release version for the PI2 and the 14262 preview version for the Pi3. The 14262 preview version will work on the pi2 as well. The 14295 version is a test version with there firewall enabled. Please dont use this version its just a firewall test for developers. 

Video
Video doesn't work. Dont expect it to. Windows is making a directx video driver but its still a ways off. Also if anyone has a minnowboard max or a dragonboard please test out video. I dont own either one and they do have accelerated graphics. 

Documents and the app.
Here is the location for both
http://scottsdigitalsignage.com/pi/
 

Lastly, most everything should work but if it doesnt it could be an issue with the browser. Microsoft is using there edge browser as the webview i do believe. Its not chrome but from what i can tell it works fairly well. 

If you have issues with the documentation please email me at support@scottsdigitalsignage.com
The documentation is mostly notes. We will make a better version of it once we are ready for a release version. 

Thanks and enjoy
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb

Posted 3 years ago

  • 3
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Awesome! Thanks William
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
I have updated the Documents and the app. The changes i made is for the preview version 14262. The reason for the change is that microsoft is now done some leg work that i no longer need to be doing in the app. I now no longer need to do the display resolution or orientation. This can be done by connecting to the device using a browser. I also no longer need the timezone setting. This also can be changed connectling to the device remotely. Recent version didnt have this option. Now with the newer builds that are coming out they will include these options. This allows me to delete those pieces and work on other things. Anyway thanks for those who are testing and playing with it. :)
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
I have added a new beta version for testing 1.0.22.0. for those who are testing. There is one bug that we are working on with Rise. The image widget using a single image has an issue where the image will show up then after a period of time it will disappear. This is a caching issue and we are working with rise to come up with a solution to fix it. We suggest to either use a placeholder with a background or use the old image gadget till we get it fixed. 
(Edited)
Photo of Ben Smith

Ben Smith

  • 250 Points 250 badge 2x thumb
Hi i just used the latest version 1.0.22.0, and now the player gets as far as the circle of dots, goes black then white then restarts and keeps going in a loop, any help greatly appreciated, using a pi3 and windows10 IOT.
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
A few things. What widgets are you using. Also be sure your using the preview version 14262. The os might update to 14279 but they both have been tested to work. Dont use the 14295 version it wont work. Also the image widget is a no go for now. Still working on a fix for it. Thanks
Photo of Ben Smith

Ben Smith

  • 250 Points 250 badge 2x thumb
Thanks for getting back to me so quick, I am on the 14262 version,  and i'm using rise clock widget, html widget, and text widget, no image widget. But i made just a blank presentation with just a red background, no placeholders etc, and that didn't even load.
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
Can you make a display id and a schedule of that prensentation. I want to see if it happens to me. Send the id to support@scottsdigitalsignage.com.

Thanks
Photo of Ben Smith

Ben Smith

  • 250 Points 250 badge 2x thumb
email sent