RiseVision display on Raspberry Pi using a web page widget pointed at a proxy.

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
Running Risevision on a Raspberry Pi. There is a web page widget on the display that is pointed at a proxy server, which then points it at a server running on a VPN network. The url listed on the widget works fine when run on the Pi's local midori browser. However when run through Risevision an cromium error pops up. Saying that there was an error. Will post the error as soon as the Pi boots. 
Photo of IQOS Support

IQOS Support

  • 340 Points 250 badge 2x thumb

Posted 4 years ago

  • 1
Photo of IQOS Support

IQOS Support

  • 340 Points 250 badge 2x thumb
Pi's booted here is the error:

Chromium can not reach the website. This is typically caused by network issues, but can also be the result of a misconfigured firewall or proxy server.

Error 109 (net::ERR_ADDRESS_UNREACHABLE): Unable to reach the server.
Photo of Justin

Justin, Employee

  • 2,526 Points 2k badge 2x thumb
Haven't seen this issue before. It's possible that the page you're trying to display has x-frame set to 'deny'....which would prevent it from loading in the web page widget. However, I cannot say that I've seen this error before. Did you find this error via console viewer? If you haven't checked there for clues, I would recommend doing that. You can bring up console in Chromium by hitting F12.

Justin
Photo of IQOS Support

IQOS Support

  • 340 Points 250 badge 2x thumb
Hi Justin: 

This error shows up on both the RiseVision player for both Windows 8 and Raspberry Pi. However the web-browser based viewer (no download) does not show this error. Am currently looking into the x-frame angle. Will let you know how that goes.
Photo of IQOS Support

IQOS Support

  • 340 Points 250 badge 2x thumb
While we try to track this down, is there anywhere where the RiseVision player would log this error, or some other equivalent of the F12 console for the RiseVision player?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
IQOS,

It looks like F12 should bring up the dev console on your raspberry pi player.
Photo of IQOS Support

IQOS Support

  • 340 Points 250 badge 2x thumb
What would be a good way to view logs from the player? Even a location of all logs would be nice to know.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
You should be able to find some logs at /rvplayer/chromium.log as well as /rvplayer/RisePlayer.log
Photo of IQOS Support

IQOS Support

  • 340 Points 250 badge 2x thumb
So it appears that our proxy server is not even receiving a request from the RiseVision widget.
Photo of IQOS Support

IQOS Support

  • 340 Points 250 badge 2x thumb
Is there a way to clear cache?

Changed the URL in the presentation to point elsewhere then checked the Windows display we have also pushed the presentation to. In the f12 debug settings under the console tab It seems that the widget is still pointing to the old address. 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
IQOS,

In windows, you can delete the folder named cache at C:\Users\'user'\AppData\Local\RVPlayer\RiseCache.

You will have to navigate to your actual user directory.
Photo of IQOS Support

IQOS Support

  • 340 Points 250 badge 2x thumb
Ok, we finally figured this one out. Totally user error. We had a duplicate presentation with the same name, the duplicate presentation still had the old invalid URL listed in it's webpage widget. Apparently schedules was using the duplicate presentation, and as it was pointing to an invalid URL it was obviously not working. After deleting the duplicate presentation, deleting the webpage widget on the correct presentation (which was apparently an older version of what is used now) re-adding the widget, and entering the URL again. Everything worked fine. 

Anyways appreciate the help, especially with the logging info.

Have a good day!
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
IQOS,

I'm glad you were able to make headway! I'm no stranger to user error myself.