RaspberryPi & RiseVision & Proxy

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
  • (Edited)
I seem to be struggling with getting the Raspberrypi and Vision working through our Proxy server, I have added the the line in the sudo visudo and saved it without the .tmp on the end

Defaults env_keep +="http_proxy https_proxy ftp_proxy no_proxy"
but it will not connect,
the unit has a static IP address set in the /etc/network/interfaces
also set the device name in etc/hostname/  as well as DNS information
From my pc I can ping the unit by name and IP, but from the Pi i can't ping my PC " unknown Host" by name but it responds via IP.

I have referenced our proxy server by its name and not IP,
If i set the unit back to DHCP  and connect it to an ADSL line with no proxy in the way it works fine and I can see the displays from the vision page,

on the pi with it set to use the proxy the chromium page opens ( so looking to connect to the vision servers to pickup my test page, it complains about the proxy, but how do you get into the settings for chromium to add the proxy details ?

This is doing my head in, and I have about 12 units to get working

any help please
Phil

FYI- I have I have also installed tightVNC as the units will have no keyboard or mouse connected and they will be on the wired LAN

It seems that the Pi can resolve dns names
Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb
  • confused

Posted 4 years ago

  • 1
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Did you go to the installer and update the CORE URL line to be http://rvaserver2.appspot.com? And to confirm, you also set the environment file with the proxy information?

Additional information can be found here, just in case.

Thanks.
Photo of Shea

Shea, Official Rep

  • 5,188 Points 5k badge 2x thumb
The above link is broken. Additional information on network requirements can be found here https://help.risevision.com/user/advanced/display/network-requirements 

Thanks
Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb
I can confirm that the core is as listed, the proxy info is in the environment, however the   risecache properties was not set with the proxy info, I have added this but now I get the following error

GDBus.Error.org.freedesktop.policykit1.Error.failed:An authentication agent already exists for the given subject.
then you get the option to  "OK " and rise player does not start ?
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Just going over everything again you have provided so far, have you tried referencing the proxy server by IP, rather than by name?
Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb
yes I have tried that, The pi can not resolve names, even though the dns servers are on the resolv.conf 
I have tried this with just the IP addresses of the DNS server,

Its very strange, If I just set it to DHCP and connect to an ADSL line ( no Proxy ) It works and can resolve names i.e www.google.com

   
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Are you using Google's DNS servers (8.8.8.8 and 8.8.4.4) or different ones?  Is the DNS on the ADSL line the same as the one that is used behind the proxy?

Thanks.
Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb
the proxy sever is on a leased line via a firewall, so the DNS servers are on our LAN All desktop pc's work fine and unix servers and AS400 etc etc.
the ADSL is a different provider and we use there DNS servers from those on the LAN
Photo of TV Screens

TV Screens

  • 600 Points 500 badge 2x thumb
All sorted, setup a firewall rule to allow the Pi's out ( bypass the proxy )