Raspberry Pi 2 with the ready to run image boots to desktop

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Hi,

We use 7 Raspberry Pi 2's with the ready to run image for more than a year. A few times we had a Raspberry Pi 2 which showed the desktop on a morning. It wasn't always the same Raspberry Pi 2. Rebooting via a ssh session didn't help. It just booted to the desktop. I have a basic knowledge of Linux and didn't know what to do, so I ended up formating the sd card. Since this one is mounted at a high ceiling it is difficult to attach a keyboard and mouse.
I was wondering if it's possible to start Chromium-browser or see what's wrong via a ssh session?
Is there someone with similar experiences?
Thanks in advance.

Best regards,
Sven
Photo of Gemeentebestuur Roosdaal

Posted 3 years ago

  • 1
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi Sven,
I would recommend also cross-posting/linking to your thread in the Raspberry Pi thread at https://community.risevision.com/rise... to give it more visibility.

Thanks
Hannah
Photo of bert shure

bert shure

  • 754 Points 500 badge 2x thumb
It seems like the desktop has to be starting from somewhere!

Was this after a reboot?

Check rc.local and all of your crontab entries.

Things happen in parallel during boot.  I'm not exactly sure how it works, but it could be the source of inconsistencies.

Look at the dmesg command and all the logs.  Try sending dmesg to a file on each Pi and comparing.

If the Pi is running, you should be able to get access to everything with SSH.

You could get a wireless keyboard and mouse, but will you be able to see the monitor?  The new PI-3's have Bluetooth built in so you don't need a dongle.

I manage several Pi's remotely.  I do have a small display that I use when I really want to see boot messages as the Pi is booting.

Cheers,

Bert
Hi Bert,

I have the Raspberry Pi in my possession. I connected a keyboard and mouse and booted it. I see the boot messages scrolling by and everything looks normal. After this I get the Desktop. I see the Trash icon and the Rise Vision backgroud. When I start the Rise Vision App or Chromium-browser nothing happens. It looks like something is wrong with Chromium-browser.
I compared /etc/rc.local and /etc/crontab with another Raspberry Pi and they look the same.
I searched on Google how I can reinstall Chromium-browser with apt-get via SSH and I found this command:
sudo apt-get install --reinstall chromium-browser
This was executed without any problems and after a reboot the Rise Vision App worked again.
I hope I can use this command again the next time Chromium-browser fails to start.

Best regards,
Sven
Photo of bert shure

bert shure

  • 754 Points 500 badge 2x thumb
Good job.
You could also think about doing full backups regularly and then if something goes wrong you can restore.