Proxy setting on windows iot /pi3

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Any one got any ideas on how to set Proxy setting on windows iot /pi3 for use with scotts digital signage app?
Photo of Ben Smith

Ben Smith

  • 250 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
Unfortunately i have no clue on how that is done on windows iot. I have looked around to see but it looks like no one has tried or figured it out. I know the app isnt coded to deal with proxies but the OS might be. I just havent found an answer for it yet. You might check the IOT forums to see if there isn't anything that someone has done or tried. 
Photo of Ben Smith

Ben Smith

  • 250 Points 250 badge 2x thumb
Thanks for your help, yeah the only way i have got to work before is rise vision linux player, which i know how to set the proxy on. 

Does your app play the content in chromium still, because i know you can launch chromium with the proxy added to the run command:

chromium --proxy-server=host:port

Am i barking up the wrong tree?

Ben
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
The first versions did but that has now been changed to edge. When we first did the app everything worked well but now its been much harder to deal with because of edge. We are going to update the app but it will be a bit later since rise is redoing there cache. We wanted to test everything out before we release a new version on it. 

As far as proxy settings, you might look up powershell proxy commands. Windows IOT has powershell on it so it could help you out in getting that set. 
Photo of Ben Smith

Ben Smith

  • 250 Points 250 badge 2x thumb
Once again thanks for help, have tried all the simple 'googled' powershell commands with no luck, On yeah had forgotten it uses edge now, Will see if i can apply a proxy to edge somehow. If i work it out will let you know!!