Problems showing image and video files

  • 3
  • Announcement
  • Updated 1 year ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

SEP 12:
A fix for the defect described below has been released with Rise Player version RisePlayerElectron 2017.09.11.22.45. 


SEP 11:
A defect was recently introduced that resuts in Image and Video Widget not showing their respective files. This impacts users with files that contain one or more special characters in the filename (e.g.,  #Test FileName.jpg). The special characters were improperly encoded resulting in an invalid URL.

An update to Rise Player was released on September 6th which includes a partial fix that should resolve the issue for a majority those impacted. However, there are scenarios we are aware of where the issue will still occur. Specifically, filenames with the special character % or #, which we are currently working on a fix for. Until that fix is released, we recommend not using the special character % or # when naming files. 

If you have been impacted by this issue, we are sorry. To ensure this doesn't happen again, we have updated our automated tests to validate that files with special characters in the filename can be retrieved and shown in a Presentation.  These test are performed pre-release and if any fail, the release will be halted. 

If you are currently experiencing this issue, please ensure the Player Version for your Display is RisePlayerElectron 2017.09.06.18.52. If you are running an older version, rebooting your Display will trigger Rise Player to auto upgrade. 

Please let us know if you have any questions. 

Thank You

Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb

Posted 1 year ago

  • 3
Photo of Robert Bisconti

Robert Bisconti

  • 322 Points 250 badge 2x thumb
My displays were effected. I wasn't using special characters in the filename, however I use a variable at the end of my image URL's so the preview will update when I update the image on the server instead of using a different filename. I am using the latest release, 2017.09.06.18.52, and this appears to now be broken.

URL Example: http://domain.com/image.jpg?v=2

I don't use special characters in the filenames, just the variable at the end. I removed the variable on my images and they are all working now.
Photo of Alex

Alex, Champion

  • 10,070 Points 10k badge 2x thumb
Hi there, we are experiencing this issue as well - but we are not using any special characters at all.  The only thing we have is a hyphen.  No spaces either.

We are using a custom URL instead of the Rise storage though - maybe this issue is affecting these links to a different extent?
Photo of Christopher Moss

Christopher Moss

  • 76 Points 75 badge 2x thumb
We are also experiencing this issue, and our display is current saying "The file does not exist or cannot be accessed."  There are no special characters in the testing filename, and the issue.  Like Alex, we are also using a custom URL and not Rise storage.
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
Since the last update which is RisePlayerElectron 2017.09.06.18.52 Standard. We have noticed that both images and videos have been getting. There was a problem retieveing the file from rise cahce. We have two that are doing this since the update. Others so far are fine. We have restarted, rebooted, and now reinstalling the player just to see if this fixes it. The images and videos are named really simple. Hopefully the reinstall fixes the issue but I believe there needs to announcements to each update. I know this is time consumming to annouce updates but i think it would be best. Also the two i have issues with are windows 10. 
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
Thanks guys. This situation is also impacting files on a 3rd party server.  We are targeting to have a fix for this today. I'll let you know once it has been released. 
Photo of Wendi Borden

Wendi Borden, Champion

  • 6,028 Points 5k badge 2x thumb
Just came to throw in my experience here too - images are not working on our Ubuntu boxes. We use our own storage and no special characters (just hyphens as Alex). Some images that were already cached are working, but images uploaded recently are not. Looking forward to the fix. Thanks :)
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
All -

A new version of Rise Player, version RisePlayerElectron 2017.09.11.22.45, has been released to address this defect. This update will be gradually rolled out over the next couple of days. When your Display reboots, Rise Player will check if an upgrade is available, but the criteria for which Display's receive the update is random. 

If your Display does not auto upgrade after rebooting, you can manually upgrade by running the latest version of Rise Player Installer appropriate for your operating system. I will provide another update once we have increased the release to 100% of all Displays. 

I am sorry for the inconvenience this has caused you. If you have any questions please don't hesitate to ask. 

Thank You. 
(Edited)
Photo of Alex

Alex, Champion

  • 10,070 Points 10k badge 2x thumb
Alan, just to verify - does this mean that if we have old versions of players out there...ie; ones that are 'not' electron...does that mean they will not receive video or picture files?
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
Deprecated versions of Rise Player have a separate code base and will continue to show images and videos.

Just note that the technology gap between the deprecated versions and where we are at today is quite large! I strongly recommend you update them in the near future. 

Thanks!
Photo of Alex

Alex, Champion

  • 10,070 Points 10k badge 2x thumb
Ok, jut wanted to know where those old ones stand.  Current plan is to upgrade them asap.  Thank you!
Photo of Alan Clayton

Alan Clayton, Official Rep

  • 8,788 Points 5k badge 2x thumb
All - 

We have updated the release for this correction to be deployed to all 100% of Displays. If your Display has not yet updated to Rise Player version RisePlayerElectron 2017.09.11.22.45, you can simply reboot to trigger the upgrade.

Thanks!
(Edited)