Problem downloading files with spaces in the filename

  • 1
  • Problem
  • Updated 1 year ago
  • Not a Problem
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Hey, all - so, I recently reinstalled Rise Player on an Intel Compute Stick that I'd had to wipe after a problem occurred with Windows Update, which means I got the latest version of the application. I found that the presentation that had previously been deployed to that stick, which I re-deployed after reinstallation, was not functioning correctly - one slide was showing OK, but everything else sat on "Waiting for video to download" forever and never came back. 

Upon examining the risecache log, I found that the working slide was downloading to the cache correctly, but all the other files reported "404 not found." I tried the URLs in a browser, and they worked fine. I managed to figure out that I could download the files manually, put them in the cache folder, and rename them to whatever token the Player was expecting, thus fooling it into thinking it had downloaded them itself, and it was able to play everything, but clearly that's not a good long-term solution.

Upon closer inspection, I noticed that the files that were failing all had spaces in their filenames. I tried renaming one of them to something without spaces, and sure enough, it downloaded correctly. I also noticed that the URLs in the log file had "%2520" for each space, instead of just the usual "%20," which makes me think that the "%" is also getting encoded, which might be the issue...not sure. Anyway, any help is appreciated! Thanks.
Photo of Gabriel Mangiante

Gabriel Mangiante

  • 70 Points

Posted 1 year ago

  • 1
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Name files without spaces... you said it yourself. I started using PCs in mid-late 90s with Windows 95-98 and since then I developed the habit to not leave empty spaces in file names )))