Presentations with google spreadsheet gadget no longer updating when spreadsheet updated...

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
In the past couple of days, my presentations have stopped updating when I update a google spreadsheet. It appears the spreadsheet gadget has recently changed to allow scrolling -- could this change have anything to do with this? The only way to update our displays now is to restart them. I find this same behavior with the "preview" function while logged into risevision. What can I do? Thanks!
Photo of sshank

sshank

  • 1,186 Points 1k badge 2x thumb

Posted 7 years ago

  • 2
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Interesting. Could you provide a copy of the Presentation to support@risevision.com? I'd like to see if I can replicate that.

Thanks.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
I've tried updating data in a spreadsheet using the Spreadsheet Gadget and it works fine for me.
Can you try clearing the cache on your Display (easiest way is to schedule a restart 30minutes in the future), or you can do it manually by following these directions.

Thanks
Photo of sshank

sshank

  • 1,186 Points 1k badge 2x thumb
Thanks, Neal.

I will try clearing the cache and report back. Meanwhile, how do I provide a copy of the presentation to that email address? Do you want to see the URL of the preview?
Photo of sshank

sshank

  • 1,186 Points 1k badge 2x thumb
I will try that. Why is it that scheduling a restart in the future will clear the cache any more than an immediate restart, which we've done many times on the machines?

Thanks a lot.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Actually, the URL that would be more beneficial is the one where you are editing the Presentation.

We figure it is easier to schedule a restart for some people depending on their level of comfort in navigating folders. Both methods will provide the same result though.

Thanks.
Photo of sshank

sshank

  • 1,186 Points 1k badge 2x thumb
I've submitted all the information requested to the support email you listed above.

Thanks!
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
We have found that this is related to the custom layout you are using. I have logged a bug for this that you can track here. We'll also announce when the bug has been closed within this post.

Thanks!
Photo of sshank

sshank

  • 1,186 Points 1k badge 2x thumb
Thanks, Neal! I just read the updates in the bug tracker and I see that it's reported as "fixed" and "verified", although I'm still experiencing the problem. Note that the presentation does not need to be republished at all -- rather, after changing something in the spreadsheet, the presentation itself needs to be refreshed (i.e., restarting the client or refreshing the browser page in the presentation preview). It's not necessary to open the presentation at all, or save it, or publish it.

Also, I wanted to be sure I mentioned that no changes were made to the presentation layout or any of the files when the updating stopped happening. The only thing that's been changing for the past few weeks or even months is the contents of the spreadsheet.

Thank you very much...I'll be so happy when I can report to my clients that it's working again!
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Sorry for the confusion. We have verified the fix on a test version of the Spreadsheet Gadget. We are now just awaiting for the fix to be deployed into Production (should be within the next couple of hours at most). Once that happens, we'll update this forum post and the defect will be marked as Deployed.

Thanks!
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Good news. The fix has been deployed. You may need to clear your cache on the Displays for these changes to take effect. Please let us know if you need any further assistance.

Thanks.
Photo of sshank

sshank

  • 1,186 Points 1k badge 2x thumb
Great! I will go and check out the systems now to see if updating takes place.

Out of curiosity, you mentioned this was related to the custom layout I was using. Was this caused by a defect or poor coding in my custom layout? Or was my layout invoking something unusual that caused the defect to come to the surface?

Thanks again for all the great support.
Photo of sshank

sshank

  • 1,186 Points 1k badge 2x thumb
Update: everything works great. Thanks again!
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Glad to hear it.

To answer your previous question, it was defect that got by us. And it is us who should be thanking you for finding it.

Thanks!
Photo of Dick Fotoples

Dick Fotoples

  • 3,142 Points 3k badge 2x thumb
I am experiencing something similar to this. I am using the spreadsheet gadget and I am setting my display colors in the spreadsheet itself.

I have to save the display, then republish it for the new changes to be truly reflected in the presentation. Otherwise, the colors in the spreadsheet (see above) display and I end up with all red or all green, or all white, whatever color the default in int he configuration.

I am working with displaying the gadgets on a black background. I vary the colors to make it easy to read. Also, more interesting to read.

Can you explain why I have to republish to get the colors in the spreadsheet to display?
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
I imagine there is some conflict if you're setting the color in the Spreadsheet itself as the Gadget also has settings for the font (including size, type, color, etc). There are also settings for the Row color (and Alternating Row color).

Can you provide more detail in how you are setting the colors? What type of updates are you making to the Spreadsheet? Are they just value updates?

Thanks.
Photo of Dick Fotoples

Dick Fotoples

  • 3,142 Points 3k badge 2x thumb
I using Google Spreadsheets for all my content. I paste all of it in the spreadsheet, change it to bold and also affect the color of the content, different color for header, then using white, yellow, green, red, I change the color of each "announcement". Of course, the content is saved as I enter it. Once I do that, I go into the presentation, click save, then publish, and the colors I have used in the spreadsheet show up accordingly in the signage display.

This is easier than trying to figure out what works as far as the gadget parameters are concerned and allows me to use different colors rather than all the content being just one color

Here is the link: http://rvauser.appspot.com/#PRESENTAT....
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Unfortunately, because the Gadget has its own font settings we haven't tried extensive testing with font colors in the Spreadsheet itself.

I've asked to see if there is a way to incorporate this and will let you know.

Thanks.
Photo of Donna Peplinskie

Donna Peplinskie

  • 7,142 Points 5k badge 2x thumb
Hi Dick,

We don't recommend using this method for styling the data in the spreadsheet. The API used to query the spreadsheet does not reliably return this information. Instead, I would recommend injecting HTML directly into your spreadsheet in order to add the colors. For example, add something like this into each cell:

<span style="color: red;">My Text</span>

There's also a blog post on this topic that can be found here.

Thx.
Photo of Wade

Wade

  • 1,238 Points 1k badge 2x thumb
I realize this is an old post, but we are experiencing an issue with Google Spreadsheet data not automatically updating within the presentation via the Google Spreadsheet Widget.

Problem #1 - Client makes changes in the Google spreadsheet and the data is not updating. 
Problem #2 - Client has populated spreadsheet data content from present date to future dates. Presentation is supposed to automatically load today's date data, but it does not. We have to manually reboot player remotely every morning.

Help please!
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Wade,

Could you provide a link to preview your presentation?
Photo of Wade

Wade

  • 1,238 Points 1k badge 2x thumb