Playlist duration versus presentation duration

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Hello -
First off - I love this program.

I am building out a distributed content system using multiple monitors at multiple locations around the nation. Currently, I have set up a schedule with two playlists:
PL1. Contains two videos inside a window - two other smaller windows on the right show slides
PL2. Near full-page window with a video and a logo

When I try to publish the schedule with both playlists, I have to enter in the total time of the videos in each playlist in order for it to play correctly. Meaning list one with two videos has a TRT of 683 seconds. Then the schedule switches to PL2 with a TRT of 148 seconds. Rinse and repeat until the cows come home.

Is there a way for the playlists to be set to run automatically for the duration of the content versus having to enter in a time in seconds for each playlist?
Photo of ACS MultimediaServices

Posted 5 years ago

  • 1
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
At this time you need to set a Duration as you have been doing.

We hope that in a future release that Presentations will have a Play until done option within the Schedule that you can choose instead of an exact time.

Thanks!
Photo of John R.V. One

John R.V. One

  • 192 Points 100 badge 2x thumb
Hi Neal and ACS, 
We are doing the same thing- adding up TRT for each presentation and then putting those into the scheduler before publishing to displays. Unfortunately, the numbers seem to be way off- 40s-4min off for each presentation. It doesn't seem to be a loading issue. We have cleared the cache several times and even changed out videos and presentations, but the TRT for the presentation won't match the timing of the schedule. Is there a 3rd duration setting somewhere that might be interfering? 
(Edited)
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
John,

There is only the Duration for the Playlist item, and the Duration set for the Presentation in the Schedule.

Do you know if the timing gets worse as playback continues?  ie, it can be off by a couple of seconds at the start, but that difference grows as playback continues?  It could be a situation where a video isn't exactly X seconds long, but maybe X.n seconds.  When the time comes to switch to a different Presentation, there may be part of the last video not completed.  When it comes time to come back to this Presentation, the video plays from where it left off, and then proceeds to play at the beginning of the Playlist.

I'm not certain if the Cenique Video gadget will pause in this instance and continue from where it left off, or will restart completely from the beginning, leaving a portion of the video to be unplayed at the very end.

Thanks.
Photo of John R.V. One

John R.V. One

  • 192 Points 100 badge 2x thumb
I don't believe there are lagging issues- the presentations run too long or are cut off, but exactly the same each time. For our first round of presentations we were able to adjust the duration TRT so the videos played through as desired. This second schedule, however, is off by much more, and we are realizing something else has to be affecting the duration. I spoke with Cenique this morning and they are looking into this issue as well. They mentioned that the PUD setting in the presentations may have been optional at one point, and that this could be affecting it. Is there a way to make this optional now?
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Play Until Done was only implemented for items within a Presentation.  They weren't implemented for Schedules.

Since the Placeholder only contains a single item (their Video Gadget), there isn't a Play Until Done situation being met here.

Do you have speakers hooked up to the display/player?  I just want to ensure that all the videos aren't playing at once in the 3 Presentations.
Photo of John R.V. One

John R.V. One

  • 192 Points 100 badge 2x thumb
Yes speakers from the tv displays are working- videos are not playing all at once, but as I described above. The TRT isn't being met or content is too short for the Duration TRT in the scheduler, causing the presentation to begin again. The seconds are added up correctly, but somehow playback  run times for presentations are off.
(Edited)