OnClick trigger not working

  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
I have an interactive presentation that includes a "Back" button to return to the previous screen.  I am using (and have tried several variations of) onclick="history.go(-1);event.preventDefault();" on that placeholder.  Works great on my local computer when in preview mode, works great using chromium on the display, but when actually running through rise it will not go back.

Any suggestions?
Photo of Joe Wakeman

Joe Wakeman

  • 162 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Joe, which widget/gadget are you using to display this content?
Photo of Joe Wakeman

Joe Wakeman

  • 162 Points 100 badge 2x thumb
Not using any widgets / gadgets, just a line in the HTML of the presentation.  I drew an empty placeholder to be the back button, and then added this code into HTML:

<div  id="backPlaceholder" placeholder="true" onclick="history.go(-1);event.preventDefault();" style="width:175px;height:74px;left:0px;top:1006px;z-index:0;position:absolute;"></div>
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Joe,

Can you try inserting that code into the html widget?
Photo of Joe Wakeman

Joe Wakeman

  • 162 Points 100 badge 2x thumb
That didn't work either.  Does the Rise player restrict chrome functionality?  F5 works to refresh, but backspace doesn't navigate back (like in a normal chrome browser)
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Joe,

Rise player does not restrict chrome functionality. I'm going to forward this on to our creative department, and they will get back to you when possible, however when dealing with custom code it's not always possible for us to troubleshoot these issues fully. Creative may only be able to help you in a general sense.