New release - The Image Folder Widget!

  • 1
  • Announcement
  • Updated 1 year ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

We have an important update for you! We have a new widget available in our store.

The Image Folder Widget is now available. Here’s a few of the features;

  • Display a slideshow of images, just by selecting the storage folder that contains them.

  • This widget checks the source folder every 15 minutes for new images, and adds them to the playlist.

  • Images scale up and down to fit the placeholder, while maintaining aspect ratio.


If you have questions about the update, please feel free to respond to this post and a support tech will get back to you as soon as possible.

You can check out a demo video on youtube.

Thanks for being a Rise Vision user, we’re dedicated to bringing you the best in open source digital signage software.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
  • Excited

Posted 4 years ago

  • 1
Photo of Tri-C Metro

Tri-C Metro

  • 1,642 Points 1k badge 2x thumb
This is awesome but it would be nice if we could schedule individual images with specific start and stop dates.  Nice addition though!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Interesting idea! You may want to consider creating an idea post for this and seeing how many others agree by hitting the Me Too button.
Photo of Patrick Howard

Patrick Howard

  • 140 Points 100 badge 2x thumb
Hi. I'm new to RiseVision. I have one display in our office. I added the Image Folder Widget to my presentation and linked it to a Storage Folder. I can see the images on the preview but the images never show up after I publish the presentation to the display. Any thoughts?
Photo of Patrick Howard

Patrick Howard

  • 140 Points 100 badge 2x thumb
Yes. I'll even add a text box to the presentation, save, publish it and the text will show up on the display but not the Image Folder Widget. 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Patrick,

Are you using the Native Player or Chrome App Player?

In order to use this widget, you will need to use Chrome App Player, details on setting up Chrome App Player on your media player are available here.
Photo of Patrick Howard

Patrick Howard

  • 140 Points 100 badge 2x thumb
We are using a C410. Just found the "Will my content run?" document from Cenique. Is the Image Folder Widget one of the widgets that's going to end up on the unsupported list?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Patrick,

That is correct, the image folder widget will not run on Android based devices at the moment.
Photo of Patrick Howard

Patrick Howard

  • 140 Points 100 badge 2x thumb
Thanks for your help Blake.
Photo of Daniel Troyer

Daniel Troyer

  • 582 Points 500 badge 2x thumb
This widget checks the source folder every 15 minutes for new images, and adds them to the playlist.
This sounds great at first, but will it pair with some sort of smart scheduling?  I'd LOVE to use this on my displays, but I run multiple presentations on my displays simultaneously.  I would need the auto-update function to also update the length of the presentation in the display schedule or I would end up with issues.

"Play until done" would be a highly valuable feature on the display schedule!
Photo of Dave

Dave

  • 2,836 Points 2k badge 2x thumb
Any plans to pull images from non-rise storage sources? Like a plain old HTTP directory?
Photo of Mauricio Escobar

Mauricio Escobar

  • 146 Points 100 badge 2x thumb
Wondering if this will work with google drive? I notice the example URL used in the video referencesgoogleapis.com and not drive.google.com
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Dave and Mauricio,

At this time the image folder widget only works with Rise Storage.
Photo of Mauricio Escobar

Mauricio Escobar

  • 146 Points 100 badge 2x thumb
Okay thank you, I appreciate all the work your team has committed to this system
Photo of Don Yost

Don Yost

  • 184 Points 100 badge 2x thumb
I created two presentations using the folder widget. Then, in schedules, I combined the two presentations.  I want the files in folder #1 to run in alphabetical order and then the files in folder #2 to run in alphabetical order. But when I preview in Chrome, the order of the slides is messed up. I'm not sure it's random, but it doesn't follow the alphabetical order of the files in each folder. I made sure that the names of the files in the two folders will give the right order even in the names are combined. In other words, the files could be dumped into the same folder and if sorted alphabetically, they would still be in the right order. I also checked to make sure that the folder widget in each of the two presentations is set to A-Z order. How can I get a schedule that will run the files in alphabetical order?
Photo of Micheal Schexnayder

Micheal Schexnayder

  • 264 Points 250 badge 2x thumb
I'm using Raspberry Pi's to display images but images aren't showing at all. I'm also testing on a Macbook and not seeing the images either. I've checked every setting in the placeholder and the image folder widget and everything seems to be in order but I'm not seeing anything. 

Any ideas? 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Michael,

The Image Folder Widget will not display on Raspberry Pi. Is your Macbook using the Rise Player Chrome Extension, or is it using Native Player?
Photo of Micheal Schexnayder

Micheal Schexnayder

  • 264 Points 250 badge 2x thumb
On my Macbook, I'm using the Chrome extension since that's what the Raspberry Pi's use. I was able to get this working again both on the Raspberry Pi's and the Macbook by playing with the storage folder. I created a new folder that had a shorter name with no special characters like spaces and -_. It started working again. So, this leads me to believe that the Chrome extension player either has a problem with long URL's for the storage OR a problem handling the spaces and special characters that might be in the name of the Risevision storage directory. 
Photo of WMU CELCIS

WMU CELCIS

  • 236 Points 100 badge 2x thumb
For some reason I can't use it. I made a folder in storage, filled it with 35 pictures..selected image folder widget, configure and then saved..it didn't do anything...if anyone has any ideas of how to help me, please email me at celcis_info@wmich.edu
Photo of WMU CELCIS

WMU CELCIS

  • 236 Points 100 badge 2x thumb
Thank you Don, my default was "all displays" the heart is green. 
Photo of WMU CELCIS

WMU CELCIS

  • 236 Points 100 badge 2x thumb
I don't want to launch the chrome player on this computer, the display ID is meant for the TV/Laptop in the front of the office. How can I get it to update (again) to the rise player chrome on that Laptop, not this computer?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
WMU,

I'm a little bit lost on what you're trying to accomplish here. You can uninstall the Rise Player Chrome extension for any display by accessing chrome://extensions in a Google Chrome browser.
Photo of WMU CELCIS

WMU CELCIS

  • 236 Points 100 badge 2x thumb
I uninstalled it, and installed it again, but it still says version 2.0. I don't know how I did it last week, I actually got it to do everything, even preview with the pictures, but now I'm back to square one. 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
WMU,

You should start by uninstalling the Rise Vision Native Player from your display, then follow this guide to install the Rise Player Chrome Extension. If you continue to have issues, one of our technicians would be happy to assist you in a 1-on-1 walkthrough or remote session. You can check out our Support Application here.
Photo of Micheal Schexnayder

Micheal Schexnayder

  • 264 Points 250 badge 2x thumb
This image folder widget does have some quirks that I hope to see ironed out in the near future. I rely on this widget quite heavily to serve content to most of my displays (all Raspberry Pi's). There has been, however, a level of frustration when it doesn't work quite like it's supposed to. :)

One of the things that I can't get to work properly is when the cache doesn't update when the storage folder updates: removed images, added images. Currently, I'm using a two phased approach to resolve this: First, I create a new storage folder each time the images need to be updated, date naming helps keep this in order. I, also, have the Raspberry Pi clear it's local cache whenever it reboots. 

Also, I believe that the widget on Raspberry Pi is responsible for the Chrome extension crashing to the desktop, so I've written a auto-detect script that checks every 2 minutes to see if the player is running, if not, reboot. I'm still investigating this issue.
Photo of Micheal Schexnayder

Micheal Schexnayder

  • 264 Points 250 badge 2x thumb
I created a new OS image for the Pi using your rvplayer-installer.sh. The rvplayer definitely brings to the table the functionality missing in my other images using the Chrome extension: Restart player, Restart Computer from the Display tab on the website. 

One thing I've noticed right away though is that I see no image folder content from any of my presentations that make use of the Image Folder Widget. The rest of the presentation is fine and the Chrome extension players are showing the content just fine. But I native player simply won't show Image folder widget content.

Here is the relevant information from a Pi running this new image:
Player version: RisePlayer 2.0.036.rsp.1
Viewer version: 1-06-038
Installed Browser: Chrome 22.0.1229.94

The browser version is odd since I installed the latest chromium-browser (37) before running the rvplayer-install.sh. I'm now unable to update the browser to the latest version. 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Michael,

Our newer widgets implement web components, which take advantage of Chrome version 36+. The older version of Chromium found in the Native Player will not support web components. Note the disclaimer on the product page here
Photo of Micheal Schexnayder

Micheal Schexnayder

  • 264 Points 250 badge 2x thumb
Thanks for the information Blake. I can't say that I'm not more than a little disappointed with this information. But it is what it is. 

So, I know its off topic here but is there plans to actually add in the feature that allows us to restart a player or computer from the Display page on the website? That was one of the things that I was really getting to like about the native player.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Michael,

Since Rise Player now runs as an extension to Google Chrome, there are not sufficient system level privileges to allow remote rebooting of a system.
Photo of Micheal Schexnayder

Micheal Schexnayder

  • 264 Points 250 badge 2x thumb
I thought you might say that. I guess my only option now is to find another way to display these images until the Image Folder Widget is able to refresh it's cache properly and reflect changes in the underlying storage folder. 

Thanks again. 
Photo of Don Yost

Don Yost

  • 184 Points 100 badge 2x thumb
Michael, do you have any problems with the Image Folder Widget playing the files in order? I want my files to play in alphabetical order, but the Image Folder Widget seems to mix them up.

I'm asking because if you're using Image Folder Widget as much as it sounds like, you must have figured out a way to get the files to play in order.

I can provide a more detailed description of the strategy I'm using if you're interested.
Photo of Micheal Schexnayder

Micheal Schexnayder

  • 264 Points 250 badge 2x thumb
I have not tried to do what you are asking but I can look into it. From your earlier post, I think I understand what you are trying to do, so replicating it shouldn't be difficult. I'll look into it and reply here when I've learned more. 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Don, Michael,

We currently have a bug logged for our developer here that addresses the issue of sorting order not working. I'm hoping to get this bumped up in priority.

Michael,

Thanks so much for the description you gave of the problems you're seeing so far. I'll get this set up for one of our support technicians to review, he'll either get back to me with a solution, or we'll get an issue logged for development.
Photo of Don Yost

Don Yost

  • 184 Points 100 badge 2x thumb
Blake,

I want to check with you to see if what I'm expecting to happen is actually how the software is desinged to work.

1. In a presentation, I open a placeholder.
2. In the item list of the placeholder, I add an Image Folder Widget
3. In the item window, I make sure that the "play until done" box is checked
4. I configure the widget to play FOLDER#1 in storage
5. I save the item
6. In the placeholder, I add a second Image Folder Widget to the list
7. Again, I make sure the "play until done" box is checked
8. I configure this second Image Folder Widget to play FOLDER#2 in storage
9. Save everything.

Expected result: The presentation will play files from FOLDER#1 and then will play files from FOLDER#2.

NOTE: I realize that there is currently a bug so that Image Folder Widget doesn't even play files from a single folder in order.

To summarize: Can I (eventually) expect a presentation to play TWO (or more) Image Folder Widgets one after the other?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Thanks for the clarification, Don. 

It looks like you're also contribution to the issue logged in the github repository for this Widget. As soon as the Content team leader can take a look at your presentation, we should be able to assign a priority to the defect.
Photo of Don Yost

Don Yost

  • 184 Points 100 badge 2x thumb
I have been tracking this issue on GitHub and it looks like the problem may be fixed. Can you tell me how I will know for sure that there is a repaired Image Folder Widget available in the store?
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Don,

I see you already communicated about this on Github earlier and that you were going to run a test later on today.  Can you please let us know how everything is once you have had a chance to try it out?
Photo of COSA DS

COSA DS

  • 60 Points
Are there any plans to add a "Show Captions"  to show the file name as the caption?
Photo of Byron

Byron, Keener

  • 9,658 Points 5k badge 2x thumb
It is in the backlog but a ways out. Thanks!
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
It seems that auto-update function is not working at times. I was testing this widget. Initially i added only one additional photo to the folder, and it showed up in the feed in 5 min or so. Then I uploaded 5 new photos and they did not get posted even after 1 hour. I was only able to force them to the screen byre-saving the presentation's schedule.

Also, what is up with navigation arrows? I set them to auto-hide, but they just keeps popping-up while the widget is in 'download' mode. Later arrows go away, but at the beginning they look pretty sporadic.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Next two upload went through, so I assume it is mostly working fine. No worries.

But them arrows, though...