My Rise Player Update V5.8

  • 1
  • Question
  • Updated 2 years ago
  • Doesn't Need an Answer
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Today we released My Rise Player for Android Mini Pc Boxes V5.8. It will be shoing up on googles servers in a few hours. This is not for the Fire TV or Nexus Player. They will be next to get the update probably next week. 

The update is more about reliablity and stability than anything. Its to help devices that seem to have a small issue where others dont. I cant fix all the devices that have small issues but this will definitely help out. Here is a list of the fixes.

Fixed issues with Rockchip processor devices crashing after the device boots.
Added 10 second delay before loading webview on startup. (Rockchip Fix) 
Added a small watcher to reload in case of a crash. Not 100% solution but its something
Added a loader dialog between the startup and the loading of webview/presentation.
Restart no longer restarts the device. It closes the app and clears the cache and reloads. 
Reboot on a specific time not longer reboots the device. It does the same as restart. Only restarts the device on a specific time and clears cache.
To reboot a device, you need to send a reboot signal from the platform. 
Updated Chrome webview library to 49. There is a viewport bug in chrome library 50 and above. Once the library is fixed we will role out chrome 50 and above. 
Other little fixes

Hopefully this will be a better app for everyone for all devices. We still feel there is improvement to be made but we are working to get everything working the way its supposed to. 

Thanks
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Jan-Eike Rosenthal

Jan-Eike Rosenthal

  • 102 Points 100 badge 2x thumb
Hi William,

first of all many thanks for putting so much work into that app. 
The problem we are facing is about a crash which happens after round about 10 after the app started. We changed the device webview & updated the app but it doesnt make a difference. The device specs are:
  • AML802 Quadcore CPU
  • Mali-450 Octacore GPU
  • Android 4.4.2 (Kit Kat)
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
We are still looking into crashes on some devices but its hard to find due to the array of devices that are out there. The question i have is it happening after the loading of the webview (10 seconds) or before. Thanks
Photo of Jan-Eike Rosenthal

Jan-Eike Rosenthal

  • 102 Points 100 badge 2x thumb
Thanks for your feedback! The presentation appears for about 10 seconds and than crashes!
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
Ok looks like all your using is the image widget. Can you make me a display ID and put a schedule on it so that i can test my devices to see if it does the same thing. It could be that your using the image widget and that the device can handle so many connections at once when downloading to cache that it might be failing. Thats the only explination but i need to test it out. Thanks
(Edited)
Photo of Jan-Eike Rosenthal

Jan-Eike Rosenthal

  • 102 Points 100 badge 2x thumb
Alright, try this: A8GNG6UE3M52
Photo of William Oneal

William Oneal, Champion

  • 13,770 Points 10k badge 2x thumb
Try updating supersu if the device uses it. The old version might be causing the issue so you might update it and see if that fixes the issue. I had the same crash but updating supersu fixed it. Let me know if that helps. Thanks
Photo of Jan-Eike Rosenthal

Jan-Eike Rosenthal

  • 102 Points 100 badge 2x thumb
We already updated the super user app. Downgrading to version 3.2 solved our problem for now.