Linux/Ubuntu Player Issue/Question?

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I mainly have Chromebox Players deployed (Which have been having issues but seem to be getting better with updating etc),
but I do have several NUC units running the Rise player with Ubuntu loaded. 2 of the locations have been great with little to no issue at all have been very happy. 

One of the Players I have been having problems. I'll restart the pc and it will run fine for few days, sometimes a week etc. But then it shows "down", I go on location and see a Purple Screen with
*Ubuntu ..... Advanced Options for Ubuntu... Memory Test (memtest86+) , 
Ill plug my keyboard in and hit "Enter", upon hitting enter the PC loads to the desktop and Pulls up Rise vision and will start displaying player signage..... Then i'll get it showing down after a period (few days,  week etc.)... I'll go back and its show this again.... Below I attached a few pictures of the "Purple" screen I am seeing that I snapped on my Cell camera.....

Anyone have any idea what this is? I am not proficient in Linux/Ubuntu functionality beyond setting these PC's up with the initial guidelines that were provided through RV.... What could be causing this, setting, something off, cache not clearing or what? Any help would be greatly appreciated!



Also as a side note, is there any documentation (guidelines, install notes etc) still around for these player versions? This player has been a heck of a lot more stable, compared to Chrome player on the chromebox devices, trying to weigh some options on what to do for future growth scale on the network. 
Photo of Mylife614 .

Mylife614 .

  • 2,326 Points 2k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Matthew Fisher

Matthew Fisher

  • 1,420 Points 1k badge 2x thumb
Official Response
Hi Chad,

There are a few suggestions on this page that can be helpful: http://askubuntu.com/questions/211797/how-do-i-make-ubuntu-power-loss-proof but the most important one is editing the grub configuration file:

sudo gedit /etc/default/grub

and adding the following line at the end (or changing the value if it already exists):
GRUB_RECORDFAIL_TIMEOUT=0

Save and exit, then run sudo update-grub2 for the changes to go into effect.

Thanks, and I hope this helps.

Matthew