I have a PNG not showing up in a placeholder. It used to work fine.

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I have a PNG in a placeholder.  It is playing in an embedded presentation.  I went to the restaurant where it is playing last night and noticed the graphic was missing. Today at my office I set up the customer on our test screen.  The same thing is happening.  The presentation is there.  The PNG in the placeholder is not.  It shows up on the preview though.  
Photo of tony

tony

  • 11,670 Points 10k badge 2x thumb

Posted 4 years ago

  • 1
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Hi Tony,

Is the PNG the only item in that Presentation?

Can you check to ensure that the Distribution and Timeline settings haven't been incorrectly set for that image?  Is the embedded Presentation Published? If the image was recently added, but the Presentation wasn't published, it may not show on the Display.

Thanks.
Photo of tony

tony

  • 11,670 Points 10k badge 2x thumb
There is a jpg background in another placeholder and a Google spreadsheet scroller at the bottom.  The spreadsheet ticker and jpg background are  working fine.  Everything is published to all screens.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Tony,

After a little digging, I believe I've found the image.  and if this is indeed the one, the image itself is set to only show until Sept 30, 2014.  It isn't readily apparent since it is the only item in that particular Placeholder.  The easy way of correcting this is temporarily adding another item to the Placeholder, such as the Text Item, then going to the Image Item and correcting the Timeline settings.  You can then remove the Text Item after this and save/publish the Presentation.

The other method of correcting this is going to the HTML and locating where the image is placed. You'll need to adjust the HTML from this:

so that it looks like this (having the start and end dates set to null and timeDefined set to false):


Thanks.
Photo of tony

tony

  • 11,670 Points 10k badge 2x thumb
Why doesn't the "end date" show in the interface in this case.  How did it get assigned an end date?  
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
The end date likely was set up when that Placeholder contained multiple items.  When the other items were removed, leaving just this one, the individual settings for the item were then hidden. This situation has been previously recorded here.

Thanks.