Issues when trying to display Dashboard reports from ServiceNow.

  • 1
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
When trying to display these reports, I have no luck. Looking for some assistance. These are view able via browser with no issues. I believe this may be https related. Any help is apprecitated.
Photo of Matt Heath

Matt Heath

  • 80 Points 75 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Hi Matt,

When you run the Presentation on a Display (or in Preview), can you open the Developer's console (press F12) and go to the Console tab.  Are there any errors listed there regarding the web page?

Thanks.
Photo of Matt Heath

Matt Heath

  • 80 Points 75 badge 2x thumb
I see these 2 errors.

GET http://preview.risevision.com/scripts/jquery-1.10.2.min.map 404 (Not Found) /scripts/jquery-1.10.2.min.map:1Refused to display 'https://owenscorningqa.service-now.com/sys_report_display.do?sysparm_report_id=c312a6146fdfa100f1d4f...' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

Thanks for the help!
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Matt,

That is a security limitation of the Dashboard. Basically it won't let another page show its content in an iFrame, which is how the Placeholder shows that content in a Presentation. 

There are some suggested fixes in this Stack Overflow post, though I have never tried any of them. Let us know if any of them fix the issue for you!