html widget couldn't load plugin

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I spent many hours last week trying to figure out looping a simple video and finally got it working, and now this week it's broken again. I'm using the HTML widget with code generated from Scene7. The error message I'm getting is "couldn't load plugin". Why can't this ever just work? Unless I want to pay money it's like I'm constatly fixing this thing and it's a little frustrating. here is the code I'm using if someone could check it out possibly?

<style type="text/css">
#s7_videoview.s7videoviewer{
width:100%;
height:auto;
}
</style>
<script type="text/javascript" language="javascript" src="http://s7d2.scene7.com/s7viewers/html5/js/VideoViewer.js"></script>;

<div id="s7_videoview"></div>
<script type="text/javascript">
var s7_videoview = new s7viewers.VideoViewer({
"containerId" : "s7_videoview",
"params" : {
"asset" : "SensataTech/Sensata Technologies - Brand Video_Original_x264",
"serverurl" : "http://s7d2.scene7.com/is/image/";,
"contenturl": "http://s7d2.scene7.com/skins/";,
"config": "SensataTech/Mag - HTML5", 
"emailurl": "http://s7d2.scene7.com/s7/emailFriend";, 
"videoserverurl": "http://s7d2.scene7.com/is/content/"} }).init();
</script>
Photo of Ben Holgate

Ben Holgate

  • 250 Points 250 badge 2x thumb
  • defeated

Posted 3 years ago

  • 1
Photo of Steve Gregory

Steve Gregory, Champion

  • 1,186 Points 1k badge 2x thumb
In the "params" section, the lines that start with "serverurl", "contenturl", and "emailurl" should end with a comma but not a semicolon.  Did you copy that script from Scene7? 
Photo of Ben Holgate

Ben Holgate

  • 250 Points 250 badge 2x thumb
Yes sir, I just tell it which video I want to publish and it spits out the code.
Photo of Ben Holgate

Ben Holgate

  • 250 Points 250 badge 2x thumb
It was working for a while
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Ben,

I wonder if you recently auto updated to the new Electron Player that does not include Flash. Check out this article for loading Flash on the Display. Let us know if that helps!
Photo of Ben Holgate

Ben Holgate

  • 250 Points 250 badge 2x thumb
I saw that article but was certain that I had changed it to HTML5 now. I should have tried that before posting because it worked. It would be nice if I could get away from Flash but I can't seem to figure it out with Scene7. I'll try and do some more research. Thank both of you for your assistance today (and always!).
Photo of Ben Holgate

Ben Holgate

  • 250 Points 250 badge 2x thumb
I'll check it out when I get back to my desk. I thought I had gotten away from using flash player but maybe not. It's a mp4 exported using html5 "skin" I guess it would call it.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Let us know how you make out Ben!
Photo of Ben Holgate

Ben Holgate

  • 250 Points 250 badge 2x thumb
Will do, I have a ticket in with Adobe now and just waiting on a reply.