HTML Video Widget skipping webm's

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I have a presentation with about 30 webM videos. The average file size is about 8 megs each but they all skip and don't play all the way though. I let them run over night last night to see if they needed more time to download to the cache but no luck. Any suggestions on how to fix this?

Thank you.
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Adrian,

How do you have the videos set to play?  Are they all simply in one presentation in one Placeholder, and using the Video item (ie, not the HTML 5 Video widget)?  Are they set to Play Until Done?  Do you have any other presentations in your Schedule or only this one?

We also released the beta of the Video Folder widget so if you are just playing all videos, can you try that new widget?  You would just create a folder in Rise Storage, upload the videos there, point to the folder and it will play whatever is in there.
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb
I should add the the videos are not down scaling to the monitor size either.
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb
Hi Alex,

each video has its own presentation using the HTML 5 video widget. I added each presentation to the schedule and set them up that way. I don't see the play until done button :(. I did see the new Video Folder yesterday but i'm using dreamhost to store all the webm's. 
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Adrian,

If you can't use the Video Folder widget, can you use the Video item for now, instead of the HTML 5 Video widget?  We are releasing a new Video widget soon to replace the HTML 5 Video widget.

Per your comment, if you have each video in a separate presentation, and then schedule each of those in a Schedule, it doesn't matter whether you have Play Until Done checked inside the widget in the presentation as the Schedule doesn't respect Play Until Done. 

Can you try creating a single presentation and then embed each of those presentations in the single presentation, and set Play Until Done on each one?  Then simply schedule that one presentation and let us know how that works out?
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb
Got it. I'll give it a shot and get back to you. Thank you.
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb
Alex, will the video scale to fit the monitor or will I have to do that manually once I plug in the chrome box? 
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Adrian, from what I understand, you are just changing from the HTML 5 Video widget to the Video item, so the videos themselves are the same and if you had them set to Scale in the widget then you should do the same thing in the Video item.

The other thing you are changing is that you are embedding the presentations in a main (parent) presentation and scheduling that one presentation versus scheduling each one individually.  With those two changes there should not be any difference in scaling.
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb
Where would I find the set to scale in the video item?
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Oops sorry, good question.  That Video item does it automatically.  
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb
hmm... not doing it on my displays... Should I be doing a new place holder for each video or put them all in the same place holder?
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
If I understood your initial post correctly, you had one video in each presentation, using the HTML 5 Video widget.

So you are:
1) Editing each of those presentations to replace the HTML 5 Video widget with the Video item.
2) Creating a main presentation with one placeholder and inside that placeholder, adding each Presentation using Add / Presentation, which embeds each presentation.

I noticed your second message where you said the videos are "not downscaling" (and that was happening with the HTML 5 Widget as well).  I thought you meant that your videos were already the same resolution as the monitor.  So it sounds to me like your presentation is not matching the monitor resolution, not the video itself.
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb
Hey Alex,

This worked perfectly. Thanks a ton!!
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Glad to hear that Adrian.  Please keep an eye on the Community here because we are going to be releasing a new Video widget soon, so you can update to that once released.
Photo of Adrian Davila

Adrian Davila

  • 200 Points 100 badge 2x thumb
will do!