How does Rise handle Shockwave / Flash Crash Errors?

  • 1
  • Question
  • Updated 4 years ago
  • Answered
While playing around with some of the presentations, one of the things I have been doing has been a presentation where you pull in lots of different webpages. I noticed after adding in to many websites (probably around 6 or more) I tend to get a shockwave crashing error. It displays a bar up at the top and I don't think it goes away until you click on it with your mouse (not always an option since you may not be aware of the error until you physically see it). I was wondering is there a way so that we can prevent these errors from showing up? Or is it possible to just disable flash ( I found that most of the time the only flash on these pages are the ads anyways). Also if it does crash does it fix the error the next time the page is set to refresh? Just curious how the current system handles these errors.
Photo of Entech Signs

Entech Signs

  • 834 Points 500 badge 2x thumb
  • slightly annoyed...

Posted 7 years ago

  • 1
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Because Flash is crashing, there is not much we can do to control that, and I don't think the Player can tell if Flash has crashed or not, but I will find out the answer to that.

When a Plugin crashes, since the browser (Chromium) does not send any sort of message to the Player saying that a plugin has crashed, it just continues to display the page.

If you notice this happening in a Presentation, and removing the Flash or offending plugin is not an option, you may want to restart the Player and Chromium every hour or so, this way the plugin is flushed from memory, and starts off all over again. Finding the right balance of how often you would restart would require some troubleshooting and guesswork. A simple VBS script should take care of that.

I'll update this post if there is any sort of message the browser sends to the Player if a plugin crashes.

Thanks!
Photo of Bryan Mullins

Bryan Mullins

  • 396 Points 250 badge 2x thumb
I am having this same problem.  I spoke with you about storage last night.  I got that worked out.  Thanks for that.  What is the script I should write to do this or is there a new solution to this?
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Bryan,

We don't have a canned script for this situation, it would be something you would need to write yourself.

If you're interested in a support subscription, our support technicians would be able to help you remedy this situation.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
I checked with our developers this morning, and unfortunately there is no way of the browser being able to tell the Player that if the plugin has crashed or not.

Sounds like a restart script may be your best option.

Thanks!
Photo of Entech Signs

Entech Signs

  • 834 Points 500 badge 2x thumb
In normal browsers usually you can disable the flash/shockwave plugin. Is this possible in chromium?? Typically I am not really interested in the flash content anyways and would rather it not run at all (also prevents the player from lagging or slowing down from the flash content).
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
I know there are several operators used when starting Chromium (such as starting it in Kiosk mode, etc). I tried a couple of different things but neither gave me the results I was looking for. I first renamed the Flash DLL in Windows and restarted the Presentation. I had the information bar at the top saying the plugin wasn't found. I then tried starting Chromium itself and accessing the Plugins page to disable Flash. After restarting the Presentation, Gadgets using Flash elements showed in the Presentation fine. I believe one of the operators when starting the Chromium via the Player is to have the Flash plugin enabled (checking that now, just waiting for the verification).
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Just received confirmation. There isn't anything in the code to force enabling the Flash plugin.
Photo of mlm

mlm, Official Rep

  • 4,624 Points 4k badge 2x thumb
Im using a vimeo video instead of youtube to avoid this shockwave crash however I still see it. I'm confused because vimeo doesn't use flash it uses html 5. In particular the crash happens when you publish a presentation and have it running in player at the same time.

Ive also seen this in other presentation I was sure had no flash.

http://rva.risevision.com/?parentId=8...

http://preview.risevision.com/Viewer....
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Mat,

The Vimeo Gadget uses a Flash Player in order to show the video in the Presentation.

We can still take a look at the Presentation to see if we can help prevent the crashes.

Thanks
Photo of Advisors Excel

Advisors Excel

  • 60 Points
was the vimeo gadget crashing ever resolved? We are seeing it crash on our presentation as well
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
I haven't seen or heard about any problems with the Vimeo gadget for a while.

Is this a recent problem you're encountering or has it been going on for an extended period of time. Does the problem persist after removing the Vimeo Gadget?

We do have a bug logged here regarding the Vimeo Gadget which you can read up on here.
Photo of RoBerto Briceño

RoBerto Briceño

  • 806 Points 500 badge 2x thumb
I'm having this problem also, vimeo player with a playlist of videos (not a vimeo channel) after certain ammount of time , it crashes. This was not happening around tree weeks ago, now it is almost for sure that it will crash after +/- 3 hours of having the display running.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Roberto,

Can you email support@risevision.com a link to the Presentation in question? Also, did this start happening yesterday, or prior to that?

Thanks.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Thanks Roberto,

I've run this twice now just to be certain.

From what I am seeing, it appears that the number of Vimeo Gadgets you have in this Presentation are too much for the Display being used. When running the Presentation, each of the Vimeo items is loaded into memory. While I know we have this bug regarding channels, have you tried running it this way to see if it does work for you?

Have you considered storing them in the Media Library (assuming you have the rights to do so), and running them as video items? I would recommend webm file formats if possible as it doesn't use Flash.
Photo of RoBerto Briceño

RoBerto Briceño

  • 806 Points 500 badge 2x thumb
Got it, i'm going to use webm videos instead and, if possible, avoid relying that much on flash player functionalities.
Thanks for your answer.