A placeholder with no content does not respect schedule settings.

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged
  • (Edited)
I have a few placeholders with certain timing applied to them. The placeholders that have no styling set, but contain playlist items are behaving as expected. They show the content at certain time of the day only. Now I want to use one of the placeholders as a semi-transparent background overlay. It has no playlist items, but has assigned background color. The problem I get with it is that this placeholder is showing there all the time; although, it has the identical timing set to it, just as the other ones. I suspect now that timing affects only the playlist items, but not the placeholder itself. Is that correct?

This is no a scheduling issue; it is only related to the timing function for placeholders within a presentation.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Darius,

Do you have a link to the Presentation in question? I'm trying to picture this and it is making my head explode a little :).
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Unfortunately, Robb, the preview is not gonna tell you lot... I do not wanna go into the details, just believe me, seeing the preview would not help you understanding this. Lets me explain as this as good as I can. Imagine two almost identical size placeholders in the same place, one on top of other (z-ordering). The bottom placeholder has no items in the playlist, but has color assigned in the properties (its purpose is to serve as a backdrop for the top placeholder; I cannot use only one placeholder in the given situation for one reason, but it is not important). The top placeholder has no color or any background image assigned, but has Calendar Widget in the playlist. Both placeholders have the timing set identically, so they appear together exactly at the same time during the day and go away also both together at the same time. The problem is that the top placeholder with Calendar Widget in the playlist maintains its timing schedule just fine, but the bottom one without anything in the playlist, but with assigned background color in the properties is visible there at all times. It seems that timing schedule is not affecting it at all.
Photo of RV News

RV News

  • 2,358 Points 2k badge 2x thumb
Hi!

In the bottom placeholder, insert a text widget without any text and set the timing. Then create and upload an image with the right color and set the timing.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Thanks, but I know how to work around that ;) I just wanted confirmation from RV people if this is actually how timing was designed to work and not some glitch that needs to be patched. 
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi Darius,

Can you please send through a preview link and we can take a look (second request..). Thanks
(Edited)
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Darius,

Just to expand on Hannah's request, we can look at the Presentation itself via the Preview link, so we can try to determine the issue here.

Thanks!
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Guys, I do not mind giving you the preview link, but it is not gonna help you. There is a number of placeholders at the same spot in the same  presentation, and they all play their content at some particular time of the day I have set by timing these placeholders. The problem with preview is that it does not care about the timing what so ever and all of the content gets played in preview at once.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Darius,

The reason we ask for a preview is because we can access the actual presentation from that link, which gives us a better understanding of what you are trying to accomplish. That being said, I don't think it's needed at the moment.

Reading the thread, I have the following understanding of the situation, please let me know if any of the following steps are incorrect.
  • Placeholder # 1 contains no content, but it does have a black background.
  • It is scheduled to play until 2:30pm
  • Placeholder #2 is slightly smaller, it contains a text widget with white fonts.
  • It is scheduled to play until 2:30pm
At 2:30pm, placeholder #2 will vanish as planned, but placeholder #1 will remain.
(Edited)
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
That is correct, Blake.
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi Darius,
We can find the presentation link from the preview due to the presentation ID in the preview (alongside associated details like schedule names, display names etc)
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Because you insisted, I created a copy of that presentation and removed some of the placeholders and left just those related to this problem: http://preview.risevision.com/?type=presentation&id=7b8d1f09-68f8-45d0-acb6-4212f6c4356d . Look where the map is. There are 3 stacked placeholders. The bottom map is always visible there. The middle one (white transparent background set in placeholder background settings; no playlist items) and the top one (Google calendar Widget playlist item; no placeholder background settings) should be visible together at the particular time of the day only. So, the top one works fine and is visible only when I need it, but the middle one never disappears; although, timing for both is identical... I checked like a thousand of times... AM... PM... everything.
(Edited)
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
So, The original presentation I made to work as expected by removing background color from placeholder settings and adding Image Widget with semi-transparent PNG overlay. And it works fine now. Apparently, timing does not affect the placeholder appearance, just embedded playlist items. Not sure if that was designed intentionally this way.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Darius,

Thanks for pointing this out. I have logged a defect for our team here.

It looks like you have a workaround by using a transparent image as a background, is that correct? If that's the case, I'm curious, on a scale of 1 - 10 (1 being least, 10 being worst), how would you say this defect is affecting you?
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Blake, yes that is what I am using as a workaround right now. It does not affect me much; it is just a simple inconvenience, and frankly, I do not like working this way, using images where code must be used. This is why I will switch to HTML Widget for rendering that background for me. But really, are you serious about that scale from 1 to 10 ))))
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Darius, very serious! As someone who works with editor day in and day out, I'd like to know from your perspective how much trouble this is causing you.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Well, in this case '2' because it dos not really stop me from achieving what I need. But then again... I feel that itch )))

Also, there is another quite surprising issue with the new editor I wanted to let you know about. While working at home on my personal Windows 10 PC I noticed that some important buttons in the new editor become inactive when I 'split' the workspace (I have work this way sometimes because I have only one monitor available). I am not getting this at work on Windows 7 and I am using Chrome browser on both machines. I think i am not able to add a placeholder when the browser tab is not if full-screen mode in Windows 10, and it also is blocking the other 2 buttons: hide/show side panel and presentation settings. I will try to not forget to take a screen shot later tonight and post it here.
(Edited)
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
A screenshot of this would be great! Thanks Darius.