How does Rise handle javascript & query running via URL or iframe?

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
We're trying to add this webpage, which dynamically grabs images and rotates through them via jquery, as part of a larger presentation. When I use this URL by itself in a placeholder it works fine, when I run it as part of a larger presentation (in a schedule in a placeholder) I get glitches, from the page not loading, to only showing some images, to a blank screen.

Are there limitations on what types of scripts can run in a presentation from a user embed? 

Is there a difference between using the Content/URL widget and embedding an <iframe> via the HTML content holder?

Page: http://www.environmentaldashboard.org/cv/?resolution=1360x692&enduse=xcollege&images=50

Full presentation: http://preview.risevision.com/Viewer.html?type=presentation&id=048cb72e-e1d2-495a-9f47-0fd5eae9c... (page is at the end, takes a few minutes to get to it)

Thanks for any assistance.
Photo of Samuel Hartman

Samuel Hartman

  • 806 Points 500 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Ashleigh

Ashleigh

  • 3,740 Points 3k badge 2x thumb
Hi Samuel,

Could you forward the presentation link in the editor?

Just to clarify - your script runs fine using the web page widget, but glitches when using the HTML widget?

Also, when I ran console I got this: 



Did you remove the <!doctype html> tag within the HTML widget? This may be causing the JQMIGRATE error.
Photo of Samuel Hartman

Samuel Hartman

  • 806 Points 500 badge 2x thumb
Thanks - just changed <html> to <!doctype html>
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Samuel,

Sounds like everything is running smoothly now, do I have that right?