Google Slide Presentation Will not Advance to Next Playlist Item

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
We have a schedule that consist of 2 playlist items.

The first item is a Google Slide Presentation that is embedded with the HTML Widget.

The second item is the Computer Aid traffic map widget.

The desired behavior I would like is to play the Google Slides in their entirety and then advance to the traffic map and then repeat.

If I add looping in the embed code and play until done in the schedule, the presentation loops and does not advance to the traffic map.

If I remove the looping, the presentation stops at the last slide and does not advance to the traffic map.

The only way I can get it to somewhat work is to remove the play until done in the schedule and set the first item in the Schedule to play for a specific number of seconds.  This has the desired affect of advancing to the traffic map and then looping back to the slide show and then repeating.  However, if I add or delete a slide, I have to change the Schedule setting to add or delete more seconds.

Does anyone know the correct settings to get the desired behavior stated above?
Photo of russojar .

russojar .

  • 102 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi,
I am currently looking into a couple of tests for this with my own copy.

Another query that I have is that if the Google Slides will consist of images only and/or if it suits your content workflow, have you considered using the Rise Storage trial and testing with the Image Widget?

Thanks!
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi,

Can I please suggest using the Web Page Widget to link to the Google Slides presentation (instead of embedding using the HTML Widget) and then running a test Schedule with the Traffic Map Widget? Let me know how that works out with this suggestion and also with the one before (using the Image Widget).

Thanks!
Photo of russojar .

russojar .

  • 102 Points 100 badge 2x thumb
H:

Thanks for looking into this.

The Web Widget does not provide the desire effect.  It show a blank white screen.  

I can't understand why the Playlist items would not advance one to the other as I had originally configured.

Using the Image Widget wold not be desired from a content editing standpoint.  Sharing the Google slides with multiple Google IDs is better than giving everyone access to RiseVision.  All the have to do is log onto to Goggle Slides, make a change and it is done.
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi,
Can you try using the Web Page Widget using the Google Slides URL provided in the embed code rather than just the published URL and it should work.
Photo of russojar .

russojar .

  • 102 Points 100 badge 2x thumb
Same thing.  Blank white screen.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
But I do not get the white screen. Both presentations are rotating properly. Initially I set them to change after 9s each, but then changed to PUD. However, I feel like 9s interval had stuck to the schedule.
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi,

The embed code link is the one highlighted in the screenshot from the Google Slides Embed tab/section:



If the link being used is in Link tab or section below it will provide a white screen error:



I’ve rolled a test copy in your account now (under Web Page Widget - RV Test). Let me know if you are still seeing the error,

Thanks,
Hannah
Photo of HSuarez

HSuarez

  • 11,896 Points 10k badge 2x thumb
Hi Darius,
The white screen error is due to Google Slides not allowing that particular link from the Link tab to be embedded in. This is the error message you see in Developer Console if you try to use that link:
(Edited)
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
russojar,

I got interested in this topic as I never used Google Slide before. After reading your post i realized that you should not embed your slides as HTML, but rather use Web Page Widget. But you NEED to make a custom basic webpage with embedded code from your slideshow. And if you do it this way here is what you get:

#1 method. 1 presentation, 1 placeholder, 2 item in playlist (web page & map), applied transition effect to placeholder, 9s per playlist item: http://preview.risevision.com/?type=p...

#2 method. 2 separate presentations (web page & map) in a schedule, 9s per each presentation: http://preview.risevision.com/?type=s...

I usually go with the method 1 in situations as such because of transition options available.

For your custom webpage you can use something like that:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml...">

Untitled Document

body {
background-color: #000;
margin-left: 0px;
margin-top: 0px;
margin-right: 0px;
margin-bottom: 0px;
}
#container {
overflow: hidden;
position: absolute;
}



Key points here are to create 1920X1080 div with hidden overflow and have your iframe embedded in there. Google slides like attaching control buttons and such which affects the final size. This is why when I made my presentation at 1920X1080, slides added that google bar at the bottom, which consequentially increased the pixel count, which would resulted in scroll bars if no 'hidden overflow' applied.

Good luck.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
Sorry, the code is messing up my post but I am too lazy to retype everything. Here is the link to the webpage file with code: http://propagandaworxcom.ipage.com/gs...
Photo of russojar .

russojar .

  • 102 Points 100 badge 2x thumb
Thank you for your response. 

I am able to get the presentation to show up with no problem and I can hide the google controls using:

<body  style="margin:0; overflow:hidden;">

My problem is the that if I use "play until done" in the schedule, the slideshow stops at the end and does not advance to the next item in the schedule.

The only way I can get it to advance is to set a specific number of seconds for the slide show to play.  That is not desirable because if you add or delete slides, you have to also change the number of seconds.
Photo of Darius - PRODO.us

Darius - PRODO.us, Champion

  • 26,850 Points 20k badge 2x thumb
I see now. So, I went ahead and changed in my schedule to 'ply until done' and it is rotating between the presentation still fine. Yet I think the schedule is still sticking to the time values I set before. However, 'play until done' totally messed up rotation between the placeholder items. All I get to see now is the traffic map. I switched back to time values again.
I think 'ply until done' it is simply not going to work as there is no way for RV to sense this kind of information from the external content that is being pushed to an iframe.
Photo of mlm

mlm, Official Rep

  • 4,624 Points 4k badge 2x thumb
Darius is correct, Rise Vision schedules have no way of knowing when anything inside a web page widget is completed playing. It looks for a done command. I would suggest not using PUD in this situation and manually tell it how long you want it to play.