Google calendar won't show

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Google Calendar will not show in the presentation via Google Calendar Gadget.  The calendar is public and I used the correct calendar ID.  What am I doing wrong?
Photo of rvms signage

rvms signage

  • 180 Points 100 badge 2x thumb
  • frustrated

Posted 4 years ago

  • 1
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Google deprecated the API that the Calendar Gadget was using.  For its replacement, we made a Calendar Widget.  You'll need to remove the old Gadget (save the calendar ID first), and then go to Add > Content > Google Calendar.  Add the calendar ID to the Widget and then save and publish your Presentation.

Thanks.
Photo of rvms signage

rvms signage

  • 180 Points 100 badge 2x thumb
Neal, I followed your steps and I still can't see the google calendar. May I send you the calendar ID?  Would that help?
Photo of rvms signage

rvms signage

  • 180 Points 100 badge 2x thumb
To be clear......when I'm in edit mode I see the placeholder that says Widget Google Calendar in it,  but when I go into preview there is nothing there.  
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
If I'm looking at the correct Presentation, then there's nothing set in the calendar itself, is that correct?
Photo of rvms signage

rvms signage

  • 180 Points 100 badge 2x thumb
I'm in the LMC presentation.  Can you see our stuff?
Photo of rvms signage

rvms signage

  • 180 Points 100 badge 2x thumb
I had removed the google calendar widget, but have just replaced it in case you can see it.
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Yes, that's the Presentation I'm looking at.  When I try the Presentation, I don't see any errors related to the Calendar Widget.  When I try the calendar ID itself to see the upcoming events, it doesn't provide any.

One possibility would be to check to ensure that the option for only sharing free/busy information is *not* checked in the calendar's settings. This can be found on the same page as where you share the calendar.

Thanks.
Photo of rvms signage

rvms signage

  • 180 Points 100 badge 2x thumb
See all events details is checked
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
If this is a Google Apps calendar (controlled from an administrator role), could it be that there's some behind the scenes block that is in place? 

Thanks.
Photo of rvms signage

rvms signage

  • 180 Points 100 badge 2x thumb
Someone else created the calendar and shared it with me.  It is public and I have privileges to manage it.  I thought it was not showing up due to the fact I had it set to show 'day' and since there was nothing on the calendar that day, that was why nothing was showing up.  But, I changed the setting to show 6 months and still nothing shows.  Arg!
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Thanks for the update.  Good to hear that the solution was found.
Photo of rvms signage

rvms signage

  • 180 Points 100 badge 2x thumb
No solution was found!
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Sorry, I misread what you meant when you said you changed it to 6 months.

When I go here: https://developers.google.com/google-apps/calendar/v3/reference/events/list and enter your calendar ID near the bottom (leaving all other fields as they are) and press Execute, I see no results indicating that there are events listed in the calendar.

For comparison, when I try this id: gm963kfm94r8sofrrhh05t0ib4@group.cale... I see a lot of events listed.

Do you have a different calendar available that you could try?
Photo of David Wolfe

David Wolfe

  • 690 Points 500 badge 2x thumb
Seems I have the same issue. When I validate using the developer tool you referenced above I see all the events on my calendar (ao5tam0pdr495ioh758gbap79o@group.cale...). But when I preview, nothing appears at all. The preview is at http://preview.risevision.com/Viewer.html?type=presentation&id=77bb513d-4b10-4434-a179-c88b7899f...
Photo of David Wolfe

David Wolfe

  • 690 Points 500 badge 2x thumb
So I found my problem at least. I saw references in various posts about the "range", but missed that option in the configure window. Unfortunately, the "range" setting is hiding in the section where the date formatting options are set. Once I found it and changed it from the default of "Day" (which makes no sense), it displays my events.