Google Calendar not updating

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I have a display setup to show my team's events using a Google Calendar.  All team members can modify/add entries onto this calendar, yet the calendar does not update on the display throughout the day as items are added/modified.

I have this calendar in two different presentations, and I get the same results in both of them.  I am using a Windows 7 embedded system on a ThinClient, using the Google Chrome Rise Player app

What are some things I can do to diagnose this problem?

FYI: If it helps this one of the presentation ID's: a75b766f-03d7-4912-8050-17f11695b5e4
Photo of Lou Laughlin

Lou Laughlin

  • 144 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
HI Lou, how long are you waiting for the display to update?  If I add or remove an item to/from my Google calendar I see it show up on the presentation within 5 minutes.  Are these displays scheduled to reboot overnight?
Photo of Lou Laughlin

Lou Laughlin

  • 144 Points 100 badge 2x thumb
Alex,  I'm waiting hours.  I was expecting at least 5-10 minutes.

It seems to only refresh if the display is restarted, or if the display PC is rebooted.  

Yes the display PC is scheduled to automatically reboot at 8pm each night with a Windows task.
(Edited)
Photo of Tun Testaa

Tun Testaa

  • 392 Points 250 badge 2x thumb
I also have the same issue.
Photo of Tun Testaa

Tun Testaa

  • 392 Points 250 badge 2x thumb
If I refresh manually with F5 then the calendar update shows.
Photo of Matthew Fisher

Matthew Fisher

  • 1,420 Points 1k badge 2x thumb
Lou & Tun,

Can you confirm what OS (and Windows version) you are using, the version of Google Chrome, and whether you're running the native player or the Chrome App version?

Thanks,

Matthew
Photo of Lou Laughlin

Lou Laughlin

  • 144 Points 100 badge 2x thumb
Here are the details that I wrote in my initial question: "I have this calendar in two different presentations, and I get the same results in both of them.  I am using a Windows 7 embedded system on a ThinClient, using the Google Chrome Rise Player app"

Here are additional details from my display screen on RiseVision

Display ID: VGXEZ97NX7NH

Operating System:
win/x86-32

Player Version:
RisePlayerPackagedApp
1.24.32

Viewer Version:
1-06-037

Player Browser: 
Auto Upgrade

Installed Browser:
Chrome 43.0.2357.81
Photo of Lou Laughlin

Lou Laughlin

  • 144 Points 100 badge 2x thumb
I'm happy that you are diagnosing my situation. In addition to resolving this, I hope you can also teach me (if possible) how I could diagnose my own problems? Is there a debug trick? Logging of activities/errors? Is there anything I could do to validate, or discover the root cause on my own?
Photo of Lou Laughlin

Lou Laughlin

  • 144 Points 100 badge 2x thumb
Thank you. That's very helpful. :-)
Photo of Tun Testaa

Tun Testaa

  • 392 Points 250 badge 2x thumb
Hi,

Display ID = ACR6F8P2HZ59
Windows 7
RisePlayer 2.0.035
Chrome 24.0.1312.56
Viewer 1-06-037

Wayne
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Wayne,

I would first recommend upgrading to our Rise Player Chrome Extension, instead of the Native Player you have installed. Please let me know if that doesn't solve your problem.
(Edited)
Photo of Clay Display

Clay Display

  • 100 Points 100 badge 2x thumb
That is a broken link.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
That post is over a year old =)

Our currently supported player is available at help.risevision.com/user/create-a-display
(Edited)
Photo of Clay Display

Clay Display

  • 100 Points 100 badge 2x thumb
Right, and you suggested a Rise Player Chrome Extension instead of the Native Player, which I cannot find. - that new link you posted doesn't list a Chrome Extension. We are having similar issues with Google Calendar, and I don't know if it's a timing issue, caching issue, etc. Thanks.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Clay,

The Chrome App Player is no longer supported, which is discussed in more detail in this forum discussion. You may also be interested to learn that Google recently said that they are stopping support for Chrome Apps in all but the Chrome OS, you can read about that here.

We would suggest installing the Windows or Linux native Player on your Display, and seeing if that solves any issues you are having. Links to both of those are available at the link Blake shared earlier.

Thanks!