Embedded Presentation - play until done not working

  • 3
  • Problem
  • Updated 4 years ago
  • Not a Problem
We are setting up multiple presentations to work as playlists for a client. For some reason, the PUD feature isn't working. In the placeholder, we have the nested presentation, along with a couple other image items. The display will only play the embedded presentation, and not get to the regular image items.

We have kind of a goofy set up, but it shouldn't affect the nested presentations...Anyone else having issues with this?
Photo of Alex

Alex, Champion

  • 10,070 Points 10k badge 2x thumb

Posted 4 years ago

  • 3
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Alex,

We've seen your email regarding the Presentations affected. We'll take a look and let you know

Thanks.
Photo of Alex

Alex, Champion

  • 10,070 Points 10k badge 2x thumb
Thanks Neal. I'm able to replicate through previewing and with the appliance. Let me know what you come up with!
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Alex,

It looks like this has something to do with the fact the embedded Presentation has items that are set for a specific date. When I make them set to show always, the Presentation progresses to the other items in the Playlist.

If you make the same changes, do you see the same thing?

Thanks.
Photo of Alex

Alex, Champion

  • 10,070 Points 10k badge 2x thumb
Hey Neal,
Actually, I did the same thing. I set all schedules to always - but I still see the same issue.

I have the presentation item set as the first item right now. At least in preview, it skips the presentation for the first cycle and plays the other content. Then when it gets back to the first item, the presentation, it plays it and gets stuck on it...playing the presentation continuously.

Would this have anything to do with the fact that this account was created before Rise had set up all accounts with the sub-account functionality? This client doesn't have a "network' tab.
Photo of Alex

Alex, Champion

  • 10,070 Points 10k badge 2x thumb
Also - just another quick note - shouldn't presentation items follow schedules just the same?
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
The embedded Presentation is in the same company as the master Presentation, is it not? At any rate, the fact that the Network tab isn't available shouldn't matter in this case.

If for whatever reason the embedded Presentation wasn't ready to play, the Playlist would go on to the next available item in the Playlist.

I was doing more thinking yesterday. Since it the embedded Playlist only contains images, would Play Until Done be necessary? Is there a point when more than 2 items in that list are showing? (thinking of a short term solution at this point).
Photo of Alex

Alex, Champion

  • 10,070 Points 10k badge 2x thumb
Hey Neal,
Yah, the embedded presentation is in the same company. It is kinda weird that it's skipped for the first cycle when it only contains images...it should be ready to play immediately. I don't remember this reacting this way.

PUD could probably be avoided for now in the short term. But this client is an expo and event stadium...they have a lot of events that change often. So the duration of the embedded presentation will be changing quite often. Using this method is by far the easiest, so hopefully this gets fixed soon.

I'm sure your developers are busy with some big things right now...but does this look like a bug?
Photo of Neal

Neal

  • 61,252 Points 50k badge 2x thumb
Alex,

Sorry for the delay in answering this. I was not able to recreate any problems with this on Friday. Are you still encountering issues with this setup?

Can you try restarting your Players (if you haven't already) to see if that clears the issue for you?

Thanks.
Photo of Dave

Dave

  • 886 Points 500 badge 2x thumb
Almost identical issues here as well. Just encountered them recently. First presentation in the containing presentation plays through, second presentation either never comes up or when it does, it loops and does not move on.

Appears to depend on the timing in the playlist, or media items in the embedded presentation, or the order in which they appear in the containing placeholder.

Was there a resolution for this issue?