Embedded presentation not working

  • 1
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
This is my main presentations:
http://rva.risevision.com/#/PRESENTATION_MANAGE/id=3d25ee54-8384-4388-889f-21598f5f2fdf?cid=98919274...

It contains number of embedded presentations scheduled to play on different days. Each of these embedded presentation has number of videos.

As on today (7th April), first two presentations (Film K L O P R and Film B S D T) should play.

But when i preview it or run it on display, it doesn't play these videos properly and randomly plays different videos even when they are not scheduled.

Ideally it should play video  K, L, O & P followed by films B, D & T (video R and S are not yet available)

Please note that all videos are hosted on Rise Vision storage.

How do i fix this issue? 
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
  • sad

Posted 4 years ago

  • 1
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Sanjay,

I just wanted to make sure that it is doing the same thing on a live display as you mention (not just Preview).  I am taking a look at the presentation but would you be able to confirm the behaviour is indeed happening on a live display?
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Sanjay, just to clarify, I don't see that main presentation scheduled so that is why I am wondering if this is only in Preview.  
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Yes it behaving like this on live display as well.
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Thanks Sanjay.  But you don't have it scheduled anymore, is that correct?  Would you be able to make copies (or not, this is just to avoid taking apart your original presentations) and reduce the number of videos in the embedded presentations so that there is only one in each, then schedule the presentation again and observe what happens and let me know?  Make sure you let it run for more than rotation of the videos.  
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Ok, will test this and let you know what happens.
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
I have carried out additional testing.

Using HTML5 Video Widget:
- Doesn't start with first video in the playlist. Randomly picks up video from the list and then follow the sequence so not very good from testing perspective because as a user i expect it to follow the playlist from top to bottom
- E.g. http://rva.risevision.com/#/PRESENTATION_MANAGE/id=12ed427e-c6c7-4e68-b423-2bb68c259567?cid=98919274-e831-4cc7-bac4-054662b21939
There are five videos: film K, L, O & P but on preview, instead of playing film K, it plays film L, O or P and then continue with playing the next item as per the playlist.

Using Video Item:
- Looks good in terms of playing videos in the playlist

Noticed another issue with both HTML5 Video Widget and Video Item is that some videos just play audio with white / black screen (no actual video). This is not consist and would be difficult to reproduce. Has anyone observed something like this?

Now coming back to original issue: not able to play scheduled embedded presentation (each embedded presentation contains number of videos).

I have noticed that if i exceed the number of embedded presentation beyond certain limit, it doesn't follow the schedule and randomly picks one of the embedded presentations.

I was able to properly play up to 4 scheduled embedded presentations so far, however my requirement is to schedule about 17 embedded presentation, which doesn't work as of now. So the limit should be some where between 4 and 17.

4 Presentations work: http://rva.risevision.com/#/PRESENTATION_MANAGE/id=a00b3d51-53c8-420f-a316-32f18d050bda?cid=98919274...

17 Presentations don't work: http://rva.risevision.com/#/PRESENTATION_MANAGE/id=3d25ee54-8384-4388-889f-21598f5f2fdf?cid=98919274...

However even with these embedded presentations, i was facing the video issue mentioned above i.e. videos don't play consistently and sometimes it's just audio with white / black screen.

Any help in this regard will be highly appreciated.
(Edited)
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Here is a test schedule for the main presentation (with 17 embedded presentations containing number of videos):
http://rva.risevision.com/#/SCHEDULE_MANAGE?cid=98919274-e831-4cc7-bac4-054662b21939

Please note that currently there is no display assigned to this schedule.
(Edited)
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Any update on this query?

Also we may change the heading of this discussion to "Scheduled Embedded Presentations not Working".
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
I think i found the issue.

Basically, if there is only one main presentation in the Schedule containing multiple embedded presentations, the system doesn't seem to recognise the schedule of these embedded presentations consistently.

However if i directly schedule these embedded presentations into the Schedule, the system seems to be working so far.

A potential explanation for this is when any change is made in the Schedule, you have to save it and the change instantly propagates to all the connected displays. But when a schedule is changed in the main presentation, you just publish it and the Schedule using this presentation may not properly receive the change.

I would like to know your thoughts on this as it is quite an important issue and may affect other members of the community.
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Here is an example of above explanation.

Test 3 Schedule: http://rva.risevision.com/#/SCHEDULE_MANAGE/id=eda293cb-3e86-47f0-884a-e6919249eabe?cid=98919274-e831-4cc7-bac4-054662b21939

This contains one main presentation and ph3 placeholder contains a presentation that has 17 embedded presentation scheduled on different days and it doesn't work.

Test 1 Schedule: http://rva.risevision.com/#/SCHEDULE_MANAGE/id=9a80c2d8-11cc-43c7-b8a4-d8c986f4750c?cid=98919274-e83...

This contains 17 main presentations (each containing 17 embedded presentations) scheduled on different days and it works.
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Sanjay,

Your example has so many items in them that it is difficult and I need to scale this down to the basics to see if there is an issue with the embedded presentations and schedules.

I just created my own test with (so far) 3 embedded presentations, each with one video in them, each scheduled to play on a different day, so over the next 3 days I will see if there is an issue as you describe.  I am not quite sure if you also scaled your tests down to something basic like I did, or did you?  
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Thanks Alex.

I have tried the scaled down version and still getting inconsistencies in schedule.

Let me know how you're test goes.

Any thoughts on why some time screen go white / black and just play audio?
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Sanjay,

This is Day 1 of my test; did you find your other videos started playing inconsistently on the first day too or was it the next day?  Since I am playing only one video on a day it is easier for me to see if there is an issue.  Also, it is my video so I am familiar with each one and will know which video is supposed to be playing on the particular day.

Is the white/black and no audio something happening with the Video item or the HTML 5 Video widget?  That sounds like a separate issue.
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
I tested it by changing the schedule of different embedded presentation during my test in order to verify that it is picking the right presentation.

Yes, as mentioned earlier, white / black and no audio happens with both HTML5 widget and Video item. 
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Okay, I am not changing the schedule on the fly, I set it up beforehand and I am just going to let it play and see what it plays on those days.  Are you making changes on the fly and that is when the issue occurs, ie you go into your presentation, edit the day/time that it is supposed to play, and then that is when you see the issue occur?  

I haven't run across the issue you described with video with the Video item.
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
It fails on the day 1 itself.

For e.g. try this presentations: http://rva.risevision.com/#/PRESENTATION_MANAGE/id=3d25ee54-8384-4388-889f-21598f5f2fdf?cid=98919274...

And as per schedule, it is supposed to plays Film ABMT today:
http://rva.risevision.com/#/PRESENTATION_MANAGE/id=1ae60629-f337-474e-902a-e31212c63368?cid=98919274...

However, it fails to play all four films - A, B, M, T.

All these films are uploaded in my Rise Vision storage account.

On the other hand, if i directly schedule these embedded presentations Film ABMT, Film CHNX etc. into a schedule, it seems to be working.
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Sanjay, I wanted to set up my own simple presentation with embedded presentations to determine if there is something not working when scheduling an embedded presentation with my own video to play on a certain day.

It started up fine yesterday playing the presentation with the video on the correct day (it was scheduled to play on Thursdays).

At midnight, it switched to the second embedded presentation with the video that is scheduled to play on Fridays.

I will see tomorrow if it plays Saturday's embedded presentation with a video.

You say yours fails on day 1 so already we are having a different experience.  I don't have 17 embedded presentations though.  I will add a few more to be scheduled on the subsequent days and let you know if that works.
Photo of Alex Kolenoff

Alex Kolenoff

  • 3,506 Points 3k badge 2x thumb
Hi Sanjay, I set up my presentation as specified above, with an embedded presentation with a single video that plays each day of the week and it played correctly for a week, switching to each video on the correct day.
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
Thanks Alex.

Unfortunately i am still not able to play first set of films.

Would you be able to test this on your machine.

Schedule: http://rva.risevision.com/#/SCHEDULE_MANAGE/id=e5f2ae87-8d45-410a-ad7d-83cb24f326d5?cid=98919274-e83...
Presentation: http://rva.risevision.com/#/PRESENTATION_MANAGE/id=3d25ee54-8384-4388-889f-21598f5f2fdf?cid=98919274...

It should play this scheduled presentation from 23/04 to 26/04.
http://rva.risevision.com/#/PRESENTATION_MANAGE/id=12ed427e-c6c7-4e68-b423-2bb68c259567?cid=98919274...

Thanks again for your feedback.
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Sanjay,

Your presentation is quite complicated and beyond what we can troubleshoot in the community. If you would like one on one support for your presentation, we offer support subscriptions at support.risevision.com.
Photo of Sanjay Kaler

Sanjay Kaler

  • 1,472 Points 1k badge 2x thumb
That's ok. I wanted to point out if Rise Vision app encounter an issue when we schedule embedded presentations (beyond certain size/number) instead of scheduling each presentation in the main schedule.

As i mentioned earlier, i am able to make it work by scheduling each presentation in the main schedule.

Thanks again for your inputs.

Regards,
Sanjay
(Edited)