Display ID is already in use

  • 3
  • Problem
  • Updated 1 year ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

My company is starting to roll out Rise Vision to display items for HR & Marketing. The small tests proved very promising. We now have 7 displays on a single schedule however, every so often they pop up with the message stating that the display ID is already in use. Each display is using its unique ID, so I am at a loss as to why this occurs. I even have a TV for our sales team that is on its own schedule and presentation that gives the same error. Any thoughts?
Photo of Dee Jarvis

Dee Jarvis

  • 120 Points 100 badge 2x thumb

Posted 2 years ago

  • 3
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Hi Dee,

I can't say that this is something we see happen very often unless there is actually a display ID configuration error. Can you ensure that all 7 displays have their own unique IDs and they are assigned correctly?
Photo of Dee Jarvis

Dee Jarvis

  • 120 Points 100 badge 2x thumb
I can verify that they all have unique ID's. It is also very intermittent. It has not occurred in the last 48 hours.
Photo of John Morrow

John Morrow

  • 94 Points 75 badge 2x thumb
This happens to me all the time and I have verified the ID's are unique.  
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Dee & John,

Could you please email support@risevision.com with one of the display IDs that you're seeing this error on?

Thanks,
Blake
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
All,

I was mistaken. This is a known issue, and has been resolved in the newest version of Rise Player. This is slated to go to 50% release today, and we anticipate 100% tomorrow barring any issues discovered. This will automatically update when your player restarts.

You can also manually reinstall by downloading the player from help.risevision.com/user/create-a-display
Photo of Nate Doelling

Nate Doelling

  • 72 Points
I have been seeing this issue for the past week. I have uninstalled the old player, re-installed the latest version, and even tried setting it up as a new display with a new ID. Within a few minutes I soon got the message again that it was already in use.
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Nate,

Can I ask you to email support@risevision.com with the Display ID that is giving you this message?
Photo of Nate Doelling

Nate Doelling

  • 72 Points
Yup. Sent. Keeping an eye on the display for the message to reappear.
Photo of AdGators AdGators

AdGators AdGators

  • 3,612 Points 3k badge 2x thumb
Hi Robb, I am seeing a Display ID is already in use today. I tested the ID's from other companies and they seem to work okay, but any new ID's in this particular company is displaying the Display ID in use. When I create a new Display ID and don't schedule any content, the presentation states that...but as soon as I schedule content (done now with a separate Schedule and Presentation) to the Display, the presentation changes to Display ID is already in use.

Thanks,
Joe Kirchner
Photo of AdGators AdGators

AdGators AdGators

  • 3,612 Points 3k badge 2x thumb
Okay, I think I've found the issue...it has to due with your Embedded Presentation Rollout...I'm going to create a new thread for this...
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Hi there Joe, we were able to recreate this error and you can track the status of this issue here: https://community.risevision.com/rise_vision_inc/topics/duplicate-display-id-error
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Joe,

I just wanted to let you know that this issue has been corrected. Thanks!