Display Being Blocked Often Please Help!

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
Display ID = 4PCRRXFU3ZQT

Not sure why this is being blocked. I read the "Blocked" thread, and none of the suggested causes apply here to the presentation I am running.

All images are hosted with RV storage, no video content is running, nothing I can see in the html is raising any major red flags for me, so I am lost. I understand the process of blocking occurs automatically when the RV servers receive an excess of requests from a display, but in this case I don't see a reason for that happening.

I am using the Chrome App to run the presentation. ( id=177b1712-89a7-4d9a-8915-79411a65f321  )  

I have no Idea what to look for in the developer tool inside of chrome. Any help you could provide would be helpful, thank you. 

FYI, the past two time this was blocked, restarting the PC fixed the issue. I have no idea why this works.
Photo of John Bagnal

John Bagnal

  • 602 Points 500 badge 2x thumb
  • Frustrated

Posted 4 years ago

  • 1
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
John,

One thing that can cause blocking is if the Presentation is consistently crashing and restarting. 

If this is a Windows machine, try running Perfmon or Task Manager while the Presentation is running to see what the CPU and memory look like while the Presentation is running. If the CPU or Memory is crashing, this can crash the Presentation to the "He's Dead Jim" face, or sometimes just freeze it, and then restart the Presentation automatically. The restarts could be the cause of the blocking.

On Linux you can use the System Monitor to look at CPU and Memory.

Let us know how you make out!
Photo of John Bagnal

John Bagnal

  • 602 Points 500 badge 2x thumb
It is not crashing by any means at a maximum it's only using 40% of the memory available to it and the CPU does not exceed 20 or so % capacity. 
Photo of John Bagnal

John Bagnal

  • 602 Points 500 badge 2x thumb
Per my associate.  "It seems to happen when he changes the distribution of a schedule.  For example he's got Schedule A running on the screen then unchecks the player PC from that schedule, saves, then check the player under Schedule B.    It's almost as if two players start up and are running at the same time."

Photo of John Bagnal

John Bagnal

  • 602 Points 500 badge 2x thumb
Furthermore, this is occurring to another display as well. While logged in to the PC running the display after a change in schedule or presentation is made it appears that the platform creates a duplicate instance of the display and this is causing the block. 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
John,

Are you running the Native player or Chrome App Player?
Photo of John Bagnal

John Bagnal

  • 602 Points 500 badge 2x thumb
Chrome App on the first one, and Native on the second display mentioned.
(Edited)
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
It looks like you're using quite a few custom html items, can you check to make sure that none of these are triggering a refresh of the presentation?

With a presentation this in depth, we won't be able to take a deep look into it in the community. You would be a great candidate for a priority support subscription. If you're interested, we can have a technician look at your presentation, put it up on a local display, and monitor the situation.
Photo of John Bagnal

John Bagnal

  • 602 Points 500 badge 2x thumb
I reviewed all html components in use, none have the "refresh" function included. This was done on purpose, to not cause issues like this. As for the priority support subscription, we may consider it, but that is not my decision to make. Thanks.
(Edited)
Photo of Phoenix West

Phoenix West

  • 192 Points 100 badge 2x thumb
I'm having the same blocked issues with two different displays. Both run Chrome on a PC. What's most difficult is the lack of reason. Without further info, it's tough to pin down the cause. Adjusting, waiting 3 hours to see....
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
John and Phoenix,

We have noticed that many cases of display blocking are due to hardware or network related issues. Can you confirm that your players are not consistently crashing, or disconnecting/reconnecting to your networks?
Photo of John Bagnal

John Bagnal

  • 602 Points 500 badge 2x thumb
Confirmed, there is no network connectivity drops and connection re-establishing occurring. It's a solid high speed connection. 
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
John,

I have your presentation up locally on my ChromeOS and Linux machines. So far I have been unable to recreate any blocking. I will let them run through tomorrow morning and let you know my results.
Photo of John Bagnal

John Bagnal

  • 602 Points 500 badge 2x thumb
Thanks man, I appreciate it. Since I first posted this issue the problem has no reoccurred to my knowledge. I am not sure what has changed, but whatever it is, it seems to be running without incident.
(Edited)