Delayed presentations

  • 1
  • Problem
  • Updated 1 year ago
  • Not a Problem
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

My organization has been using RiseVision for a few years now and today I rolled out a whole new look and feel to our schedule. Ever since this morning. our various displays have not worked - only the background and sometimes the time and weather app work. It has only worked on our newest display, which has a faster computer, but none of the others. Has anyone had this issue? Is there something I'm doing wrong/could be doing to get the displays to show correctly, faster? I have a due date for the roll-out and would appreciate any feedback.  
Photo of MidwayUSA HR

MidwayUSA HR

  • 130 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Robb

Robb, Official Rep

  • 76,676 Points 50k badge 2x thumb
Hi there,

One thing I noticed looking at your Company, is that you are running very old versions of the RIse Vision Player on your Displays, that would be the first thing that I would get corrected before you continue troubleshooting. You can download the latest version of the Windows Player from here: https://help.risevision.com/hc/en-us/articles/115000860926-Displays

Let me know if that helps!
Photo of MidwayUSA HR

MidwayUSA HR

  • 130 Points 100 badge 2x thumb
That does help, we are currently testing that now. Does it make a difference that I was deleting presentations that are not currently scheduled to display? 
Photo of Mike Thomas

Mike Thomas

  • 1,282 Points 1k badge 2x thumb
Hello,

Removing a presentation that wasn't in use won't affect this. :) Let us know if you have any further questions!

Regards,
Mike Thomas
Rise Vision Support