Custom layout spreadsheet does not update.

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged
Hello,

I had this posted as a comment on another post, but it seems to be a different problem.

The presentation was updating when I was using the default layout in preview.  Now that I am using a different (custom) layout, even the preview doesn't update when I make changes to the spreadsheet.  On the device, it was never consistent in updating, even with the default layout.  The spreadsheet is definitely set up properly and the widget is set to refresh every 5 minutes.  The point of my using the spreadsheet was to have the automatic updating functionality without having to manually refresh the display.  There are many occasions where we need the presentation to update fairly quickly.

On a different note.  The widget (or my browser) is caching the layout file.  this means that every time I want to change the layout (a lot right now since I'm still developing the layout) I have to change the name of the layout file in order to force it to update.  This is not insurmountable but is kind of annoying.

Any solutions?

Thanks,
Steven
Photo of Steven

Steven

  • 150 Points 100 badge 2x thumb
  • frustrated

Posted 4 years ago

  • 1
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Steven,

Unfortunately there isn't much troubleshooting I can do on custom layouts. If you can replicate this bug with the standard layout, I can log an issue for our developers to look at for you.

When you say that the default layout was inconsistent in updating, what do you mean? Did it vary by minutes, or hours?
(Edited)
Photo of Steven

Steven

  • 150 Points 100 badge 2x thumb
It worked ok in preview, but almost never on the devices (C110).  I set the devices to restart the app once an hour, which is better than nothing but much worse than every 5 minutes.

Is there a reason that the layout would modify the way that the widget functions?  A way for the layout to overwrite the update preferences?

Thanks,
Steven
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Steven

Unfortunately the C110 uses a completely different version of the player than preview/Rise Vision Player uses. It sounds like we could have a couple of forks in the road here, one being the custom layout, and two being the player itself. I would clarify with Cenique Support that they have tested the Spreadsheet Widget along with custom layouts on their players.

I don'tthink that a custom layout would modify how the widget functions, however I'll pick the brain of our developers to see if they have any ideas of why it would.

Thanks for the heads up on this issue, let me know how Cenique responds!
Photo of Steven

Steven

  • 150 Points 100 badge 2x thumb
Cenique offered the possibility of some kind of gateway problem because of our network security.  But is not aware of any difficulties with the spreadsheet widget on their devices.  Unfortunately, this does not actually fix the problem that I have with the spreadsheet widget.

For the moment I will be modifying the settings on the devices to restart the app every hour in order to get updates more often.  It is not the 5 minutes I was hoping for but it's better than once a day.

Thanks,
Steven
Photo of Steven

Steven

  • 150 Points 100 badge 2x thumb
I have spent some time discussing this issue with Cenique support.  We have worked through some of the major test cases and the issue does seem to be related to the custom layout.

The standard layout was fairly predictable in its updating.  Once I switched to the custom test layout (using html https://storage.googleapis.com/risemedialibrary-340fe58c-6c5e-4dd1-bd4b-d9ab25031922/layout5.html) I have been unable to get the updating to work at all. This custom layout is only a slight modification from the list example layout.  Is there something that I am missing in the layout itself?

Thanks,
Steven
Photo of Blake Freeman

Blake Freeman, Official Rep

  • 36,116 Points 20k badge 2x thumb
Steven,

Please see the issue logged here regarding custom layouts. Your input on the issue would be very much appreciated.